Puppet Enterprise console远程代码执行漏洞

CVE编号

CVE-2016-5716

利用情况

暂无

补丁情况

N/A

披露时间

2017-08-10
漏洞描述
Puppet是美国Puppet实验室的一套基于客户端/服务器(C/S)架构的配置管理工具,它可用于管理配置文件、用户、cron任务、软件包、系统服务等。Puppet Enterprise是一个企业版。console是其中的一个控制台工具。

Puppet Enterprise 2015.x版本和2016.4.0之前的2016.x版本中的console存在安全漏洞。远程攻击者可利用该漏洞在控制台节点上执行代码。
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://puppet.com/security/cve/pe-console-oct-2016
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 puppet puppet_enterprise 2015.2.0 -
运行在以下环境
应用 puppet puppet_enterprise 2015.2.1 -
运行在以下环境
应用 puppet puppet_enterprise 2015.2.2 -
运行在以下环境
应用 puppet puppet_enterprise 2015.2.3 -
运行在以下环境
应用 puppet puppet_enterprise 2015.3.0 -
运行在以下环境
应用 puppet puppet_enterprise 2015.3.1 -
运行在以下环境
应用 puppet puppet_enterprise 2015.3.2 -
运行在以下环境
应用 puppet puppet_enterprise 2015.3.3 -
运行在以下环境
应用 puppet puppet_enterprise 2016.1.1 -
运行在以下环境
应用 puppet puppet_enterprise 2016.1.2 -
运行在以下环境
应用 puppet puppet_enterprise 2016.2.0 -
运行在以下环境
应用 puppet puppet_enterprise 2016.2.1 -
CVSS3评分
8.8
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-134 使用外部控制的格式字符串
阿里云安全产品覆盖情况