低危 libgd越界读取漏洞

CVE编号

CVE-2016-6132

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-08-13
漏洞描述
libgd是一个开源的用于动态创建图像的库,它支持创建图表、图形和缩略图等。

libgd未能正确解析TGA文件,远程攻击者可利用该漏洞造成越边界读取。
解决建议
用户可参考如下厂商提供的安全补丁以修复该漏洞:
https://github.com/libgd/libgd/issues/247
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libgd libgd * Up to
(including)
2.2.2
运行在以下环境
系统 alpine_3.4 gd * Up to
(excluding)
2.2.3-r0
运行在以下环境
系统 debian DPKG * Up to
(excluding)
2.2.2-29-g3c2b605-1
运行在以下环境
系统 debian_8 gd * Up to
(excluding)
2.1.0-5+deb8u3
运行在以下环境
系统 fedora_24 gd * Up to
(excluding)
2.2.3-1.fc24
运行在以下环境
系统 opensuse_13.2 gd * Up to
(excluding)
2.1.0-7.11.1
运行在以下环境
系统 opensuse_Leap_42.1 gd * Up to
(excluding)
2.1.0-10.1
运行在以下环境
系统 suse_12 gd * Up to
(excluding)
2.1.0-12
运行在以下环境
系统 suse_12_SP1 gd * Up to
(excluding)
2.1.0-12.1
运行在以下环境
系统 ubuntu_14.04 gd * Up to
(excluding)
2.1.0-3ubuntu0.3
运行在以下环境
系统 ubuntu_14.04.6_lts libgd2 * Up to
(excluding)
2.1.0-3ubuntu0.3
运行在以下环境
系统 ubuntu_16.04 gd * Up to
(excluding)
2.1.1-4ubuntu0.16.04.3
运行在以下环境
系统 ubuntu_16.04.7_lts libgd2 * Up to
(excluding)
2.1.1-4ubuntu0.16.04.3
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况