中危 PowerDNS区域传输数据限制拒绝服务漏洞

CVE编号

CVE-2016-6172

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-09-27
漏洞描述
PowerDNS是一个跨平台的开源DNS服务组件,它支持在Windows系统中使用Access的mdb文件记录DNS信息,在Linux/Unix系统中使用MySQL来记录DNS信息。

PowerDNS服务器中存在拒绝服务漏洞,该漏洞源于程序未能限制区域传输数据的大小。攻击者可利用该漏洞造成拒绝服务。
解决建议
用户可参考如下厂商提供的安全补丁以修复该漏洞:
https://powerdns.com/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 powerdns authoritative_server * Up to
(including)
4.0.0
运行在以下环境
系统 debian DPKG * Up to
(excluding)
4.0.1-1
运行在以下环境
系统 debian_7 pdns * Up to
(excluding)
3.1-4.1+deb7u2
运行在以下环境
系统 debian_8 pdns * Up to
(excluding)
3.4.1-4+deb8u3
运行在以下环境
系统 fedora_24 pdns * Up to
(excluding)
4.0.1-1.fc24
运行在以下环境
系统 fedora_EPEL_6 pdns * Up to
(excluding)
3.3.3-2.el6
运行在以下环境
系统 opensuse leap 42.1 -
运行在以下环境
系统 opensuse opensuse 13.2 -
运行在以下环境
系统 opensuse_Leap_42.1 pdns * Up to
(excluding)
3.4.6-3.1
运行在以下环境
系统 ubuntu_18.04.5_lts pdns * Up to
(excluding)
4.0.1-1
运行在以下环境
系统 ubuntu_18.04_lts pdns * Up to
(excluding)
4.0.1-1
运行在以下环境
系统 ubuntu_18.10 pdns * Up to
(excluding)
4.0.1-1
阿里云评分
4.1
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-400 未加控制的资源消耗(资源穷尽)
阿里云安全产品覆盖情况