低危 GD Graphics Library up to 2.2.3 TIFF Image dynamicGetbuf 越界读取漏洞

CVE编号

CVE-2016-6911

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-01-27
漏洞描述
2.2.4之前的GD Graphics Library(又称为 libgd)中的dynamicGetbuf函数允许远程攻击者通过精心设计的TIFF图像导致拒绝服务(越界读取)。

解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:

https://github.com/libgd/libgd/commit/4859d69e07504d4b0a4bdf9bcb4d9e3769ca35ae
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libgd libgd * Up to
(including)
2.2.3
运行在以下环境
系统 debian DPKG * Up to
(excluding)
2.2.3-87-gd0fec80-2
运行在以下环境
系统 debian_7 gd * Up to
(excluding)
2.0.36~rc1~dfsg-6.1+deb7u6
运行在以下环境
系统 debian_8 gd * Up to
(excluding)
2.1.0-5+deb8u9
运行在以下环境
系统 fedora_23 gd * Up to
(excluding)
2.1.1-11.fc23
运行在以下环境
系统 fedora_24 gd * Up to
(excluding)
2.2.3-5.fc24
运行在以下环境
系统 fedora_25 gd * Up to
(excluding)
2.2.3-5.fc25
运行在以下环境
系统 opensuse_13.2 gd * Up to
(excluding)
5.6.1-83.1
运行在以下环境
系统 opensuse_Leap_42.1 gd * Up to
(excluding)
2.1.0-13.1
运行在以下环境
系统 opensuse_Leap_42.2 gd * Up to
(excluding)
5.5.14-65.1
运行在以下环境
系统 suse_11_SP4 gd * Up to
(excluding)
2.0.36.RC1-52.25.1
运行在以下环境
系统 suse_12 gd * Up to
(excluding)
2.1.0-23
运行在以下环境
系统 suse_12_SP1 gd * Up to
(excluding)
2.1.0-17.1
运行在以下环境
系统 ubuntu_12.04.5_lts libgd2 * Up to
(excluding)
2.0.36~rc1~dfsg-6ubuntu2.3
运行在以下环境
系统 ubuntu_14.04 gd * Up to
(excluding)
2.1.0-3ubuntu0.5
运行在以下环境
系统 ubuntu_14.04.6_lts libgd2 * Up to
(excluding)
2.1.0-3ubuntu0.5
运行在以下环境
系统 ubuntu_16.04 gd * Up to
(excluding)
2.1.1-4ubuntu0.16.04.5
运行在以下环境
系统 ubuntu_16.04.7_lts libgd2 * Up to
(excluding)
2.1.1-4ubuntu0.16.04.5
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况