低危 OpenSSL ECDSA P-256私钥获取漏洞

CVE编号

CVE-2016-7056

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-09-11 05:29:00
漏洞描述
OpenSSL是OpenSSL团队开发的一个开源的能够实现安全套接层(SSL v2/v3)和安全传输层(TLS v1)协议的通用加密库,它支持多种加密算法,包括对称密码、哈希算法、安全散列算法等。
OpenSSL中存在安全漏洞,该漏洞源于crypto/ec/ecdsa_ossl.c文件的‘ecdsa_sign_setup()’函数未能正确的设置BN_FLG_CONSTTIME标识。本地攻击者利用该漏洞实施cache-timing攻击,获取ECDSA P-256私钥。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,详情请关注厂商主页:
https://www.openssl.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 openssl openssl * Up to
(including)
1.0.1u
2
运行在以下环境
系统 fedora_EPEL_5 openssl * Up to
(excluding)
1.0.1e-10.el5
3
运行在以下环境
系统 suse_11_SP4 openssl * Up to
(excluding)
0.9.8j-0.105.1
4
运行在以下环境
系统 opensuse_Leap_42.1 openssl * Up to
(excluding)
2.5.3-13.1
5
运行在以下环境
系统 opensuse_Leap_42.2 openssl * Up to
(excluding)
2.5.3-5.3.1
6
运行在以下环境
系统 debian_7 openssl * Up to
(excluding)
1.0.1e-2+deb7u11
7
运行在以下环境
系统 debian_8 openssl * Up to
(excluding)
1.0.1t-1+deb8u8
8
运行在以下环境
系统 suse_12_SP1 openssl * Up to
(excluding)
1.0.1i-54.5.1
9
运行在以下环境
系统 suse_12_SP2 openssl * Up to
(excluding)
0.9.8j-105.1
10
运行在以下环境
系统 opensuse_Leap_42.3 openssl * Up to
(excluding)
1.0.2k-4.3.1
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
阿里云安全产品覆盖情况