低危 PHP堆缓冲区溢出漏洞(CNVD-2016-07335)

CVE编号

CVE-2016-7134

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-09-12
漏洞描述
PHP 是一种新型的CGI程序编写语言。

PHP存在堆缓冲区溢出漏洞。远程攻击者可利用此漏洞覆盖4个字节的堆缓冲区,造成拒绝服务或执行任意代码。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
https://bugs.php.net/bug.php?id=72674
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 php php 7.0.0 -
运行在以下环境
应用 php php 7.0.1 -
运行在以下环境
应用 php php 7.0.2 -
运行在以下环境
应用 php php 7.0.3 -
运行在以下环境
应用 php php 7.0.4 -
运行在以下环境
应用 php php 7.0.5 -
运行在以下环境
应用 php php 7.0.6 -
运行在以下环境
应用 php php 7.0.7 -
运行在以下环境
应用 php php 7.0.8 -
运行在以下环境
应用 php php 7.0.9 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0
运行在以下环境
系统 opensuse_13.2 php5-bcmath * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-curl * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-dba * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-enchant-debuginfo * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-fileinfo-debuginfo * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-firebird-debuginfo * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-gett * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-gettext-debuginfo * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-intl-debuginfo * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-json * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-ldap * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-mcrypt * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-mssql * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-odbc-debuginfo * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-opcache * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-pear * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-phar * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-phar-debuginfo * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-posix * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-posix-debuginfo * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-shmop * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-shmop-debuginfo * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-soap * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-sqlite * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-sysvmsg * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-sysvmsg-debuginfo * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-tidy * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-tidy-debuginfo * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-tokenizer * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-tokenizer-debuginfo * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-xmlrpc * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-xsl-debuginfo * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-zip * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_13.2 php5-zlib * Up to
(excluding)
5.6.1-75.2
运行在以下环境
系统 opensuse_Leap_42.1 php5-bcmath * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-curl * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-dba * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-enchant-debuginfo * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-fileinfo-debuginfo * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-firebird-debuginfo * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-gett * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-gettext-debuginfo * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-intl-debuginfo * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-json * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-ldap * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-mcrypt * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-mssql * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-odbc-debuginfo * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-opcache * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-pear * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-phar * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-phar-debuginfo * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-posix * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-posix-debuginfo * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-shmop * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-shmop-debuginfo * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-soap * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-sqlite * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-sysvmsg * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-sysvmsg-debuginfo * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-tidy * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-tidy-debuginfo * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-tokenizer * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-tokenizer-debuginfo * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-xmlrpc * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-xsl-debuginfo * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-zip * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 opensuse_Leap_42.1 php5-zlib * Up to
(excluding)
5.5.14-59.1
运行在以下环境
系统 suse_12 apache2-mod_php5 * Up to
(excluding)
5.5.14-73
运行在以下环境
系统 ubuntu_16.04 php7.0 * Up to
(excluding)
7.0.8-0ubuntu0.16.04.3
运行在以下环境
系统 ubuntu_16.04.7_lts php7.0 * Up to
(excluding)
7.0.8-0ubuntu0.16.04.3
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况