低危 cURL/libcURL证书验证安全绕过漏洞

CVE编号

CVE-2016-7141

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-10-04
漏洞描述
在使用NSS和libnsspem.so库构建的7.50.2之前的curl和libcurl在运行时可用时,允许远程攻击者通过充分利用文件中先前加载的客户端证书的重用来劫持TLS连接的身份验证,其未设置证书,此漏洞与CVE-2016-5420不同。

解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:

https://curl.haxx.se/docs/adv_20160907.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 haxx libcurl * Up to
(including)
7.50.1
运行在以下环境
系统 alpine_3.10 curl * Up to
(excluding)
7.50.2
运行在以下环境
系统 alpine_3.11 curl * Up to
(excluding)
7.50.2
运行在以下环境
系统 alpine_3.12 curl * Up to
(excluding)
7.50.2-r0
运行在以下环境
系统 alpine_3.13 curl * Up to
(excluding)
7.50.2-r0
运行在以下环境
系统 alpine_3.14 curl * Up to
(excluding)
7.50.2-r0
运行在以下环境
系统 alpine_3.15 curl * Up to
(excluding)
7.50.2-r0
运行在以下环境
系统 alpine_3.2 curl * Up to
(excluding)
7.49.1-r2
运行在以下环境
系统 alpine_3.3 curl * Up to
(excluding)
7.49.1-r2
运行在以下环境
系统 alpine_3.4 curl * Up to
(excluding)
7.50.2-r0
运行在以下环境
系统 alpine_3.5 curl * Up to
(excluding)
7.50.2-r0
运行在以下环境
系统 alpine_3.6 curl * Up to
(excluding)
7.50.2
运行在以下环境
系统 alpine_3.7 curl * Up to
(excluding)
7.50.2
运行在以下环境
系统 alpine_3.8 curl * Up to
(excluding)
7.50.2
运行在以下环境
系统 alpine_3.9 curl * Up to
(excluding)
7.50.2
运行在以下环境
系统 alpine_edge curl * Up to
(excluding)
7.50.2-r0
运行在以下环境
系统 amazon linux_AMI curl * Up to
(excluding)
7.47.1-8.65.amzn1
运行在以下环境
系统 amazon_AMI curl * Up to
(excluding)
7.47.1-8.65.amzn1
运行在以下环境
系统 debian DPKG * Up to
(excluding)
7.51.0-1
运行在以下环境
系统 debian_7 curl * Up to
(excluding)
7.26.0-1+wheezy15
运行在以下环境
系统 debian_8 curl * Up to
(excluding)
7.38.0-4+deb8u1
运行在以下环境
系统 opensuse leap 42.1 -
运行在以下环境
系统 opensuse_Leap_42.1 curl * Up to
(excluding)
7.37.0-13.1
运行在以下环境
系统 oracle linux_7 curl * Up to
(excluding)
7.29.0-35.el7
运行在以下环境
系统 oracle_7 curl * Up to
(excluding)
7.29.0-35.el7
运行在以下环境
系统 redhat_7 curl * Up to
(excluding)
0:7.29.0-35.el7
运行在以下环境
系统 sles_11_SP4 curl * Up to
(excluding)
7.19.7-1.70.13.1
运行在以下环境
系统 sles_12 sles12-docker-image * Up to
(excluding)
1.1.4-20171002
运行在以下环境
系统 sles_12_SP1 curl * Up to
(excluding)
7.37.0-28.1
运行在以下环境
系统 suse_11_SP4 curl * Up to
(excluding)
7.19.7-1.70.13.1
运行在以下环境
系统 suse_12_SP1 curl * Up to
(excluding)
7.37.0-28.1
运行在以下环境
系统 ubuntu_12.04_lts curl * Up to
(excluding)
7.22.0-3ubuntu4.17
运行在以下环境
系统 ubuntu_14.04 curl * Up to
(excluding)
7.35.0-1ubuntu2.10
运行在以下环境
系统 ubuntu_14.04_lts curl * Up to
(excluding)
7.35.0-1ubuntu2.10
运行在以下环境
系统 ubuntu_16.04 curl * Up to
(excluding)
7.47.0-1ubuntu2.2
运行在以下环境
系统 ubuntu_16.04_lts curl * Up to
(excluding)
7.47.0-1ubuntu2.2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-287 认证机制不恰当
阿里云安全产品覆盖情况