低危 ImageMagick PSD File coders/psd.c 越界写入漏洞

CVE编号

CVE-2016-7535

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-04-21
漏洞描述
ImageMagick是美国ImageMagick Studio公司的一套开源的图象处理软件。ImageMagick中的文件存在安全漏洞,远程攻击者可借助PSD文件利用该漏洞造成拒绝服务。
解决建议

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:

https://github.com/ImageMagick/ImageMagick/issues/128
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 imagemagick imagemagick - -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
8:6.9.6.2+dfsg-2
运行在以下环境
系统 debian_7 imagemagick * Up to
(excluding)
8:6.7.7.10-5+deb7u8
运行在以下环境
系统 debian_8 imagemagick * Up to
(excluding)
8:6.8.9.9-5+deb8u2
运行在以下环境
系统 opensuse_13.2 imagemagick * Up to
(excluding)
6.8.9.8-34.1
运行在以下环境
系统 opensuse_Leap_42.1 imagemagick * Up to
(excluding)
6.8.8.1-21.1
运行在以下环境
系统 suse_11_SP4 imagemagick * Up to
(excluding)
6.4.3.6-7.54.1
运行在以下环境
系统 suse_12 ImageMagick * Up to
(excluding)
6.8.8.1-70
运行在以下环境
系统 suse_12_SP1 imagemagick * Up to
(excluding)
1-6.8.8.1-40.1
运行在以下环境
系统 ubuntu_12.04.5_lts imagemagick * Up to
(excluding)
8:6.6.9.7-5ubuntu3.5
运行在以下环境
系统 ubuntu_14.04.6_lts imagemagick * Up to
(excluding)
8:6.7.7.10-6ubuntu3.2
运行在以下环境
系统 ubuntu_16.04 imagemagick * Up to
(excluding)
8:6.8.9.9-7ubuntu5.2
运行在以下环境
系统 ubuntu_16.04.7_lts imagemagick * Up to
(excluding)
8:6.8.9.9-7ubuntu5.2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况