低危 GNU Bash本地命令执行漏洞

CVE编号

CVE-2016-7543

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-01-20 09:59:00
漏洞描述
GNU Bash是美国软件开发者布莱恩-福克斯(Brian J. Fox)为GNU计划而编写的一个Shell(命令语言解释器),它运行于类Unix操作系统中(Linux系统的默认Shell),并能够从标准输入设备或文件中读取、执行命令,同时也结合了一部分ksh和csh的特点。

GNU Bash中存在本地命令执行漏洞。本地攻击者可利用该漏洞在应用程序上下文中执行任意命令。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,详情请关注厂商主页:
http://www.gnu.org/software/bash/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu bash * Up to
(including)
4.3
运行在以下环境
系统 amazon_AMI bash * Up to
(excluding)
4.2.46-28.37.amzn1
运行在以下环境
系统 debian_7 bash * Up to
(excluding)
4.2+dfsg-0.1+deb7u4
运行在以下环境
系统 debian_8 bash * Up to
(excluding)
4.3-11+deb8u1
运行在以下环境
系统 fedora_23 bash * Up to
(excluding)
4.3.42-5.fc23
运行在以下环境
系统 fedora_24 bash * Up to
(excluding)
4.3.42-7.fc24
运行在以下环境
系统 fedora_25 bash * Up to
(excluding)
4.3.43-4.fc25
运行在以下环境
系统 opensuse_13.2 bash * Up to
(excluding)
4.2-75.5.1
运行在以下环境
系统 opensuse_Leap_42.1 bash * Up to
(excluding)
6.2-81.1
运行在以下环境
系统 opensuse_Leap_42.3 bash * Up to
(excluding)
4.3-83.6.1
运行在以下环境
系统 oracle_6 bash * Up to
(excluding)
4.1.2-48.el6
运行在以下环境
系统 oracle_7 bash * Up to
(excluding)
4.2.46-28.el7
运行在以下环境
系统 suse_11_SP4 bash * Up to
(excluding)
5.2-147.29.1
运行在以下环境
系统 suse_12_SP1 bash * Up to
(excluding)
4.2-82.1
运行在以下环境
系统 suse_12_SP3 bash * Up to
(excluding)
4.3-83.10.1
运行在以下环境
系统 ubuntu_14.04 bash * Up to
(excluding)
4.3-7ubuntu1.7
运行在以下环境
系统 ubuntu_16.04 bash * Up to
(excluding)
4.3-14ubuntu1.2
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况