低危 PHP GD Graphics Library整数溢出漏洞

CVE编号

CVE-2016-7568

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-09-29
漏洞描述
PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHP Group和开放源代码社区共同维护的一种开源的通用计算机脚本语言。该语言支持多重语法、支持多数据库及操作系统和支持C、C++进行程序扩展等。GD Graphics Library(又名libgd或libgd2)是美国软件开发者Thomas Boutell所研发的一个开源的用于动态创建图像的库,它支持创建图表、图形和缩略图等。

PHP 7.0.11之前版本使用的GD Graphics Library 2.2.3及之前的版本中的gd_webp.c文件中的‘dImageWebpCtx’函数存在整数溢出漏洞。远程攻击者可借助‘imagewebp’和‘imagedestroyllows’函数调用利用该漏洞造成拒绝服务(堆缓冲区溢出)。

解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
https://github.com/libgd/libgd/issues/308
https://bugs.php.net/bug.php?id=73003
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libgd libgd * Up to
(including)
2.2.3
运行在以下环境
应用 php php * From
(including)
5.6.0
Up to
(including)
5.6.26
运行在以下环境
应用 php php * From
(including)
7.0.0
Up to
(including)
7.0.11
运行在以下环境
系统 alpine_3.4 gd * Up to
(excluding)
2.2.3-r1
运行在以下环境
系统 debian DPKG * Up to
(excluding)
5.6.27+dfsg-0+deb8u1
运行在以下环境
系统 debian_8 gd * Up to
(excluding)
2.1.0-5+deb8u3
运行在以下环境
系统 fedora_23 gd * Up to
(excluding)
2.1.1-11.fc23
运行在以下环境
系统 fedora_24 gd * Up to
(excluding)
2.2.3-5.fc24
运行在以下环境
系统 fedora_25 gd * Up to
(excluding)
2.2.3-5.fc25
运行在以下环境
系统 opensuse_13.2 gd * Up to
(excluding)
2.1.0-7.19.1
运行在以下环境
系统 opensuse_Leap_42.1 gd * Up to
(excluding)
2.1.0-13.1
运行在以下环境
系统 opensuse_Leap_42.2 gd * Up to
(excluding)
5.5.14-65.1
运行在以下环境
系统 suse_12 gd * Up to
(excluding)
2.1.0-23
运行在以下环境
系统 suse_12_SP1 gd * Up to
(excluding)
2.1.0-17.1
运行在以下环境
系统 ubuntu_14.04 gd * Up to
(excluding)
2.1.0-3ubuntu0.5
运行在以下环境
系统 ubuntu_14.04.6_lts libgd2 * Up to
(excluding)
2.1.0-3ubuntu0.5
运行在以下环境
系统 ubuntu_16.04 gd * Up to
(excluding)
2.1.1-4ubuntu0.16.04.5
运行在以下环境
系统 ubuntu_16.04.7_lts libgd2 * Up to
(excluding)
2.1.1-4ubuntu0.16.04.5
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-190 整数溢出或超界折返
阿里云安全产品覆盖情况