低危 libass up to 0.13.3 libass/ass_shaper.c check_allocations 拒绝服务漏洞

CVE编号

CVE-2016-7972

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-03-04
漏洞描述
libass是一个轻量级的对ASS/SSA格式字幕进行渲染的函数库。

Libass中存在安全绕过漏洞,远程攻击者可以利用漏洞绕过安全机制执行未经认证的操作。
解决建议
目前厂商已发布更新,参考链接如下:
https://github.com/libass/libass/pull/240/commits/aa54e0b59200a994d50a346b5d7ac818ebcf2d4b
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libass_project libass * Up to
(including)
0.13.3
运行在以下环境
系统 alpine_3.10 libass * Up to
(excluding)
0.13.4-r0
运行在以下环境
系统 alpine_3.11 libass * Up to
(excluding)
0.13.4-r0
运行在以下环境
系统 alpine_3.12 libass * Up to
(excluding)
0.13.4-r0
运行在以下环境
系统 alpine_3.13 libass * Up to
(excluding)
0.13.4-r0
运行在以下环境
系统 alpine_3.14 libass * Up to
(excluding)
0.13.4-r0
运行在以下环境
系统 alpine_3.15 libass * Up to
(excluding)
0.13.4-r0
运行在以下环境
系统 alpine_3.16 libass * Up to
(excluding)
0.13.4-r0
运行在以下环境
系统 alpine_3.3 libass * Up to
(excluding)
0.13.4-r0
运行在以下环境
系统 alpine_3.4 libass * Up to
(excluding)
0.13.4-r0
运行在以下环境
系统 alpine_3.5 libass * Up to
(excluding)
0.13.4-r0
运行在以下环境
系统 alpine_3.6 libass * Up to
(excluding)
0.13.4-r0
运行在以下环境
系统 alpine_3.7 libass * Up to
(excluding)
0.13.4-r0
运行在以下环境
系统 alpine_3.8 libass * Up to
(excluding)
0.13.4-r0
运行在以下环境
系统 alpine_3.9 libass * Up to
(excluding)
0.13.4-r0
运行在以下环境
系统 alpine_edge libass * Up to
(excluding)
0.13.4-r0
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0.13.4-1
运行在以下环境
系统 debian_7 libass * Up to
(excluding)
0.10.0-3+deb7u1
运行在以下环境
系统 fedoraproject fedora 23 -
运行在以下环境
系统 fedoraproject fedora 24 -
运行在以下环境
系统 fedoraproject fedora 25 -
运行在以下环境
系统 fedora_23 libass * Up to
(excluding)
0.13.4-1.fc23
运行在以下环境
系统 fedora_24 libass * Up to
(excluding)
0.13.4-1.fc24
运行在以下环境
系统 fedora_25 libass * Up to
(excluding)
0.13.4-1.fc25
运行在以下环境
系统 fedora_EPEL_7 libass * Up to
(excluding)
0.13.4-1.el7
运行在以下环境
系统 opensuse leap 42.1 -
运行在以下环境
系统 opensuse opensuse 13.2 -
运行在以下环境
系统 opensuse_Leap_42.1 libass * Up to
(excluding)
0.12.3-6.1
运行在以下环境
系统 sles_12 libass5 * Up to
(excluding)
0.10.2-3
运行在以下环境
系统 sles_12_SP1 libass * Up to
(excluding)
0.10.2-3.1
运行在以下环境
系统 sles_12_SP2 libass * Up to
(excluding)
0.10.2-3.1
运行在以下环境
系统 suse_12 libass5 * Up to
(excluding)
0.10.2-3
运行在以下环境
系统 suse_12_SP1 libass * Up to
(excluding)
0.10.2-3.1
运行在以下环境
系统 suse_12_SP2 libass * Up to
(excluding)
0.10.2-3.1
运行在以下环境
系统 ubuntu_12.04.5_lts libass * Up to
(excluding)
0.10.0-3+deb7u1build0.12.04.1
运行在以下环境
系统 ubuntu_12.04_lts libass * Up to
(excluding)
0.10.0-3+deb7u1build0.12.04.1
运行在以下环境
系统 ubuntu_18.04.5_lts libass * Up to
(excluding)
1:0.13.4-2
运行在以下环境
系统 ubuntu_18.04_lts libass * Up to
(excluding)
1:0.13.4-2
运行在以下环境
系统 ubuntu_18.10 libass * Up to
(excluding)
1:0.13.4-2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-399 资源管理错误
阿里云安全产品覆盖情况