低危 受损服务器通过事实变量进行命令注入

CVE编号

CVE-2016-8628

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-08-01 09:29:00
漏洞描述
版本2.2.0之前的Ansible无法正确清理从可应答控制器发送的事实变量。能够在控制器上创建特殊变量的攻击者可以在用户ansible运行时在可应答客户端上执行任意命令。&nbsp;<br />
&nbsp;
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
https://bugzilla.redhat.com/show_bug.cgi?id=1388113
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat ansible * Up to
(excluding)
2.2.0
2
运行在以下环境
系统 opensuse_Leap_42.2 ansible * Up to
(excluding)
2.4.1.0-6.1
3
运行在以下环境
系统 opensuse_Leap_42.3 ansible * Up to
(excluding)
2.4.1.0-6.1
4
运行在以下环境
系统 fedora_EPEL_6 ansible * Up to
(excluding)
2.2.0.0-2.el6
5
运行在以下环境
系统 fedora_24 ansible * Up to
(excluding)
2.2.0.0-2.fc24
6
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.2.0.0-2.el7
7
运行在以下环境
系统 fedora_25 ansible * Up to
(excluding)
2.2.0.0-2.fc25
8
运行在以下环境
系统 opensuse_Leap_42.2 ansible * Up to
(excluding)
2.4.1.0-6.1
9
运行在以下环境
系统 opensuse_Leap_42.3 ansible * Up to
(excluding)
2.4.1.0-6.1
10
运行在以下环境
系统 opensuse_Leap_42.2 ansible * Up to
(excluding)
2.4.1.0-6.1
11
运行在以下环境
系统 opensuse_Leap_42.3 ansible * Up to
(excluding)
2.4.1.0-6.1
12
运行在以下环境
系统 fedora_EPEL_6 ansible * Up to
(excluding)
2.2.0.0-2.el6
13
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.2.0.0-2.el7
14
运行在以下环境
系统 ubuntu_16.04 ansible * Up to
(excluding)
2.0.0.2-2ubuntu1.1
15
运行在以下环境
系统 fedora_EPEL_6 ansible * Up to
(excluding)
2.2.0.0-3.el6
16
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.2.0.0-3.el7
阿里云评分
2.4
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    管控权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-77 在命令中使用的特殊元素转义处理不恰当(命令注入)
阿里云安全产品覆盖情况