中危 在某些情况下,mysql_user模块可能无法正确更改密码

CVE编号

CVE-2016-8647

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-07-27 03:29:00
漏洞描述
在2.2.1.0之前的Ansible的mysql_user模块中发现了输入验证漏洞,在某些情况下可能无法正确更改密码。因此,以前的密码在应该更改时仍然是活动的。<br>
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://github.com/ansible/ansible-modules-core/pull/5388
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat ansible_engine * Up to
(excluding)
2.2.1.0
2
运行在以下环境
应用 redhat virtualization 4.1 -
3
运行在以下环境
系统 fedora_24 ansible * Up to
(excluding)
2.2.1.0-1.fc24
4
运行在以下环境
系统 fedora_EPEL_6 ansible * Up to
(excluding)
2.2.1.0-1.el6
5
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.2.1.0-1.el7
6
运行在以下环境
系统 fedora_25 ansible * Up to
(excluding)
2.2.1.0-1.fc25
7
运行在以下环境
系统 fedora_EPEL_6 ansible * Up to
(excluding)
2.2.1.0-1.el6
8
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.2.1.0-1.el7
阿里云评分
4.2
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    管控权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况