低危 PHP LibGD栈缓冲区溢出漏洞

CVE编号

CVE-2016-8670

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-01-05
漏洞描述
libGD是一个开源的用于动态创建图像的库,它支持创建图表、图形和缩略图等。

PHP LibGD存在栈缓冲区溢出漏洞,允许远程攻击者可利用该漏洞提交特殊请求,进行拒绝服务攻击。
解决建议
用户可联系供应商获得补丁信息:
https://github.com/libgd/libgd/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libgd libgd * Up to
(including)
2.2.3
运行在以下环境
应用 php php * Up to
(including)
5.6.27
运行在以下环境
应用 php php 7.0.0 -
运行在以下环境
应用 php php 7.0.1 -
运行在以下环境
应用 php php 7.0.10 -
运行在以下环境
应用 php php 7.0.11 -
运行在以下环境
应用 php php 7.0.12 -
运行在以下环境
应用 php php 7.0.2 -
运行在以下环境
应用 php php 7.0.3 -
运行在以下环境
应用 php php 7.0.4 -
运行在以下环境
应用 php php 7.0.5 -
运行在以下环境
应用 php php 7.0.6 -
运行在以下环境
应用 php php 7.0.7 -
运行在以下环境
应用 php php 7.0.8 -
运行在以下环境
应用 php php 7.0.9 -
运行在以下环境
系统 amazon_AMI gd * Up to
(excluding)
5.6.29-1.131.amzn1
运行在以下环境
系统 debian DPKG * Up to
(excluding)
2.2.3-87-gd0fec80-1
运行在以下环境
系统 debian_7 gd * Up to
(excluding)
2.0.36~rc1~dfsg-6.1+deb7u6
运行在以下环境
系统 debian_8 gd * Up to
(excluding)
2.1.0-5+deb8u9
运行在以下环境
系统 fedora_23 gd * Up to
(excluding)
2.1.1-11.fc23
运行在以下环境
系统 fedora_24 gd * Up to
(excluding)
2.2.3-5.fc24
运行在以下环境
系统 fedora_25 gd * Up to
(excluding)
2.2.3-5.fc25
运行在以下环境
系统 opensuse_13.2 gd * Up to
(excluding)
5.6.1-83.1
运行在以下环境
系统 opensuse_Leap_42.1 gd * Up to
(excluding)
2.1.0-13.1
运行在以下环境
系统 opensuse_Leap_42.2 gd * Up to
(excluding)
5.5.14-65.1
运行在以下环境
系统 suse_11_SP4 gd * Up to
(excluding)
2.0.36.RC1-52.25.1
运行在以下环境
系统 suse_12 gd * Up to
(excluding)
2.1.0-23
运行在以下环境
系统 suse_12_SP1 gd * Up to
(excluding)
2.1.0-17.1
运行在以下环境
系统 ubuntu_12.04.5_lts libgd2 * Up to
(excluding)
2.0.36~rc1~dfsg-6ubuntu2.3
运行在以下环境
系统 ubuntu_14.04 gd * Up to
(excluding)
2.1.0-3ubuntu0.5
运行在以下环境
系统 ubuntu_14.04.6_lts libgd2 * Up to
(excluding)
2.1.0-3ubuntu0.5
运行在以下环境
系统 ubuntu_16.04 gd * Up to
(excluding)
2.1.1-4ubuntu0.16.04.5
运行在以下环境
系统 ubuntu_16.04.7_lts libgd2 * Up to
(excluding)
2.1.1-4ubuntu0.16.04.5
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况