低危 cURL/libcURL缓冲区溢出漏洞

CVE编号

CVE-2016-9586

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-04-24
漏洞描述
当在libcurl执行printf()函数时输出大的浮点输出时,版本7.52之前的卷曲容易受到缓冲区溢出的影响。如果有任何应用程序从外部接受格式字符串而没有必要的输入过滤,则它可以允许远程攻击。

解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
https://curl.haxx.se/docs/adv_20161221A.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 haxx curl * Up to
(excluding)
7.52.0
运行在以下环境
系统 alpine_3.2 curl * Up to
(excluding)
7.52.1-r0
运行在以下环境
系统 alpine_3.3 curl * Up to
(excluding)
7.52.1-r0
运行在以下环境
系统 amazon_AMI curl * Up to
(excluding)
7.47.1-9.70.amzn1
运行在以下环境
系统 debian_7 curl * Up to
(excluding)
7.26.0-1+wheezy18
运行在以下环境
系统 debian_8 curl * Up to
(excluding)
7.38.0-4+deb8u1
运行在以下环境
系统 fedora_24 curl * Up to
(excluding)
7.47.1-10.fc24
运行在以下环境
系统 fedora_25 curl * Up to
(excluding)
7.51.0-4.fc25
运行在以下环境
系统 opensuse_Leap_42.1 curl * Up to
(excluding)
7.37.0-16.3.1
运行在以下环境
系统 opensuse_Leap_42.2 curl * Up to
(excluding)
7.37.0-16.3.1
运行在以下环境
系统 suse_11_SP4 curl * Up to
(excluding)
7.19.7-1.70.3.1
运行在以下环境
系统 suse_12_SP1 curl * Up to
(excluding)
7.37.0-36.1
运行在以下环境
系统 suse_12_SP2 curl * Up to
(excluding)
7.37.0-36.1
运行在以下环境
系统 ubuntu_14.04 curl * Up to
(excluding)
7.35.0-1ubuntu2.11
运行在以下环境
系统 ubuntu_16.04 curl * Up to
(excluding)
7.47.0-1ubuntu2.3
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
CWE-122 堆缓冲区溢出
阿里云安全产品覆盖情况