低危 受损的远程主机可能导致在Ansible控制器上运行命令

CVE编号

CVE-2016-9587

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-04-25 05:29:00
漏洞描述
在Ansible处理从客户端系统发送的数据时,版本2.1.4,2.2.1之前的Ansible容易受到不正确的输入验证的影响。控制由Ansible管理的客户端系统的攻击者以及将事实发送回Ansible服务器的能力可以使用此缺陷使用Ansible服务器权限在Ansible服务器上执行任意代码。
解决建议
用户可参考如下厂商提供的安全补丁以修复该漏洞:
https://www.ansible.com/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 ansible ansible * Up to
(excluding)
2.1.4
2
运行在以下环境
应用 ansible ansible * Up to
(excluding)
2.2.1
3
运行在以下环境
应用 redhat openstack 11.0 -
4
运行在以下环境
系统 opensuse_Leap_42.2 ansible * Up to
(excluding)
2.4.1.0-6.1
5
运行在以下环境
系统 opensuse_Leap_42.3 ansible * Up to
(excluding)
2.4.1.0-6.1
6
运行在以下环境
系统 alpine_3.4 ansible * Up to
(excluding)
2.1.4.0-r0
7
运行在以下环境
系统 alpine_3.5 ansible * Up to
(excluding)
2.2.1.0-r0
8
运行在以下环境
系统 fedora_24 ansible * Up to
(excluding)
2.2.1.0-1.fc24
9
运行在以下环境
系统 fedora_25 ansible * Up to
(excluding)
2.2.1.0-1.fc25
10
运行在以下环境
系统 fedora_EPEL_6 ansible * Up to
(excluding)
2.3.0.0-1.el6
11
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.3.0.0-1.el7
12
运行在以下环境
系统 fedora_26 ansible * Up to
(excluding)
2.3.0.0-1.fc26
13
运行在以下环境
系统 opensuse_Leap_42.2 ansible * Up to
(excluding)
2.4.1.0-6.1
14
运行在以下环境
系统 opensuse_Leap_42.3 ansible * Up to
(excluding)
2.4.1.0-6.1
15
运行在以下环境
系统 opensuse_Leap_42.2 ansible * Up to
(excluding)
2.4.1.0-6.1
16
运行在以下环境
系统 opensuse_Leap_42.3 ansible * Up to
(excluding)
2.4.1.0-6.1
17
运行在以下环境
系统 ubuntu_16.04 ansible * Up to
(excluding)
2.0.0.2-2ubuntu1.1
18
运行在以下环境
系统 fedora_EPEL_6 ansible * Up to
(excluding)
2.3.0.0-1.el6
19
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.3.0.0-1.el7
20
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.3.0.0-3.el7
21
运行在以下环境
系统 fedora_EPEL_6 ansible * Up to
(excluding)
2.3.0.0-3.el6
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况