中危 Apple macOS up to 10.12.5 curl 跨站脚本攻击

CVE编号

CVE-2016-9594

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-04-24
漏洞描述
Haxx curl和libcurl都是瑞典Haxx公司的产品。curl是一套利用URL语法在命令行下工作的文件传输工具。libcurl是一个免费、开源的客户端URL传输库。

Haxx libcurl 7.52.0版本和curl 7.52.1之前的版本中存在远程安全绕过漏洞。攻击者可利用该漏洞绕过安全限制,执行未授权的操作。
解决建议
用户可联系供应商获得补丁信息:
https://curl.haxx.se/docs/adv_20161223.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 haxx curl * Up to
(excluding)
7.52.1
运行在以下环境
系统 alpine_3.10 curl * Up to
(excluding)
7.52.1
运行在以下环境
系统 alpine_3.11 curl * Up to
(excluding)
7.52.1
运行在以下环境
系统 alpine_3.12 curl * Up to
(excluding)
7.52.1-r0
运行在以下环境
系统 alpine_3.13 curl * Up to
(excluding)
7.52.1-r0
运行在以下环境
系统 alpine_3.14 curl * Up to
(excluding)
7.52.1-r0
运行在以下环境
系统 alpine_3.15 curl * Up to
(excluding)
7.52.1-r0
运行在以下环境
系统 alpine_3.2 curl * Up to
(excluding)
7.52.1-r0
运行在以下环境
系统 alpine_3.3 curl * Up to
(excluding)
7.52.1-r0
运行在以下环境
系统 alpine_3.4 curl * Up to
(excluding)
7.52.1-r0
运行在以下环境
系统 alpine_3.5 curl * Up to
(excluding)
7.52.1-r0
运行在以下环境
系统 alpine_3.6 curl * Up to
(excluding)
7.52.1
运行在以下环境
系统 alpine_3.7 curl * Up to
(excluding)
7.52.1
运行在以下环境
系统 alpine_3.8 curl * Up to
(excluding)
7.52.1
运行在以下环境
系统 alpine_3.9 curl * Up to
(excluding)
7.52.1
运行在以下环境
系统 alpine_edge curl * Up to
(excluding)
7.52.1-r0
阿里云评分
5.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    N/A
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-665 初始化不恰当
阿里云安全产品覆盖情况