低危 Red Hat JBoss Core Services xpointer.c 拒绝服务漏洞

CVE编号

CVE-2016-9597

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-07-31
漏洞描述
Libxml2是GNOME项目组所研发的一个基于C语言的用来解析XML文档的函数库。

Libxml2存在基于栈的缓冲区溢出漏洞,该漏洞源于程序未对用户输入执行正确的边界检查。攻击者可利用该漏洞在受影响应用程序的上下文中执行任意代码,导致拒绝服务。
解决建议
用户可参考如下厂商提供的安全补丁以修复该漏洞:
https://bugzilla.redhat.com/show_bug.cgi?id=1408305
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 hp icewall_federation_agent 3.0 -
运行在以下环境
应用 hp icewall_file_manager 3.0 -
运行在以下环境
应用 xmlsoft libxml2 2.9.3 -
运行在以下环境
系统 canonical ubuntu_linux 12.04 -
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 15.10 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0
运行在以下环境
系统 opensuse leap 42.1 -
运行在以下环境
系统 opensuse_Leap_42.2 libxml2 * Up to
(excluding)
2.9.4-3.1
运行在以下环境
系统 opensuse_Leap_42.2 libxml2-2-32bit * Up to
(excluding)
2.9.4-3.1
运行在以下环境
系统 opensuse_Leap_42.2 libxml2-tools * Up to
(excluding)
2.9.4-3.1
运行在以下环境
系统 opensuse_Leap_42.2 python-libxml2 * Up to
(excluding)
2.9.4-3.1
运行在以下环境
系统 sles_12 sles12-docker-image * Up to
(excluding)
1.1.4-20171002
运行在以下环境
系统 sles_12_SP1 libxml2 * Up to
(excluding)
2-2.9.1-26.12.1
运行在以下环境
系统 sles_12_SP1 libxml2-2-32bit * Up to
(excluding)
2-2.9.1-26.12.1
运行在以下环境
系统 sles_12_SP1 libxml2-tools * Up to
(excluding)
2-2.9.1-26.12.1
运行在以下环境
系统 sles_12_SP1 python-libxml2 * Up to
(excluding)
2-2.9.1-26.12.1
运行在以下环境
系统 sles_12_SP2 libxml2 * Up to
(excluding)
2.9.4-33.1
运行在以下环境
系统 sles_12_SP2 libxml2-2-32bit * Up to
(excluding)
2.9.4-33.1
运行在以下环境
系统 sles_12_SP2 libxml2-tools * Up to
(excluding)
2.9.4-33.1
运行在以下环境
系统 sles_12_SP2 python-libxml2 * Up to
(excluding)
2.9.4-33.1
运行在以下环境
系统 suse_12 sles12-docker-image * Up to
(excluding)
1.1.4-20171002
运行在以下环境
系统 suse_12_SP1 python-libxml2 * Up to
(excluding)
2.9.1-26.12.1
运行在以下环境
系统 suse_12_SP2 python-libxml2 * Up to
(excluding)
2.9.4-33.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况