Puppet Enterprise Communications Protocol Broker Crash 拒绝服务漏洞

CVE编号

CVE-2016-9686

利用情况

暂无

补丁情况

N/A

披露时间

2017-02-09
漏洞描述
Puppet是一套基于客户端/服务器架构的配置管理工具,它可用于管理配置文件、用户、cron任务、软件包、系统服务等。Puppet Enterprise是一个企业版。

Puppet Enterprise中的Puppet Communications Protocol (PCP) Broker存在安全漏洞,由于程序未能正确的验证消息头大小。攻击者可利用该漏洞造成PCP Broker崩溃。
解决建议
目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:
https://puppet.com/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 puppet puppet_enterprise * From
(including)
2016.4.0
Up to
(excluding)
2016.4.3
运行在以下环境
应用 puppet puppet_enterprise 2016.5.1 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0
CVSS3评分
5.3
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况