低危 PHP 至 5.6.27/7.0.12 WDDX null 指针取消引用漏洞

CVE编号

CVE-2016-9933

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-01-05
漏洞描述
PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHP Group和开放源代码社区共同维护的一种开源的通用计算机脚本语言。该语言支持多重语法、支持多数据库及操作系统和支持C、C++进行程序扩展等。

PHP 'src/gd.c'存在拒绝服务漏洞,攻击者可利用漏洞发起拒绝服务攻击。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
https://bugs.php.net/bug.php?id=72696
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libgd libgd 2.2.1 -
运行在以下环境
应用 php php * Up to
(including)
5.6.27
运行在以下环境
应用 php php 7.0.0 -
运行在以下环境
应用 php php 7.0.1 -
运行在以下环境
应用 php php 7.0.10 -
运行在以下环境
应用 php php 7.0.11 -
运行在以下环境
应用 php php 7.0.2 -
运行在以下环境
应用 php php 7.0.3 -
运行在以下环境
应用 php php 7.0.4 -
运行在以下环境
应用 php php 7.0.5 -
运行在以下环境
应用 php php 7.0.6 -
运行在以下环境
应用 php php 7.0.7 -
运行在以下环境
应用 php php 7.0.8 -
运行在以下环境
应用 php php 7.0.9 -
运行在以下环境
系统 amazon_AMI gd * Up to
(excluding)
5.6.29-1.131.amzn1
运行在以下环境
系统 debian DPKG * Up to
(excluding)
2.2.2-29-g3c2b605-1
运行在以下环境
系统 debian_7 gd * Up to
(excluding)
2.0.36~rc1~dfsg-6.1+deb7u7
运行在以下环境
系统 debian_8 gd * Up to
(excluding)
5.6.20+dfsg-0+deb8u1
运行在以下环境
系统 opensuse_13.2 gd * Up to
(excluding)
2.1.0-7.22.1
运行在以下环境
系统 opensuse_Leap_42.1 gd * Up to
(excluding)
2.1.0-13.1
运行在以下环境
系统 opensuse_Leap_42.2 gd * Up to
(excluding)
2.1.0-13.1
运行在以下环境
系统 suse_11_SP4 gd * Up to
(excluding)
2.0.36.RC1-52.29.1
运行在以下环境
系统 suse_12 gd * Up to
(excluding)
2.1.0-23
运行在以下环境
系统 suse_12_SP1 gd * Up to
(excluding)
2.1.0-20.1
运行在以下环境
系统 suse_12_SP2 gd * Up to
(excluding)
2.1.0-20.1
运行在以下环境
系统 ubuntu_12.04.5_lts libgd2 * Up to
(excluding)
2.0.36~rc1~dfsg-6ubuntu2.4
运行在以下环境
系统 ubuntu_14.04 gd * Up to
(excluding)
2.1.0-3ubuntu0.6
运行在以下环境
系统 ubuntu_14.04.6_lts libgd2 * Up to
(excluding)
2.1.0-3ubuntu0.6
运行在以下环境
系统 ubuntu_16.04 gd * Up to
(excluding)
2.1.1-4ubuntu0.16.04.6
运行在以下环境
系统 ubuntu_16.04.7_lts libgd2 * Up to
(excluding)
2.1.1-4ubuntu0.16.04.6
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况