中危 Haxx libcurl 'verify_certificate'函数越边界读取漏洞

CVE编号

CVE-2016-9953

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-03-13
漏洞描述
Haxx libcurl是瑞典Haxx公司的一个免费、开源的客户端URL传输库。该库支持FTP、FTPS、TFTP、HTTP等。

Haxx libcurl 7.30.0版本至7.51.0版本中的libtls/schannel.c文件的'verify_certificate'函数存在安全漏洞。远程攻击者可利用该漏洞造成拒绝服务(崩溃)或获取敏感信息(越边界读取)。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://curl.haxx.se/docs/adv_20161221C.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 haxx curl * From
(including)
7.30.0
Up to
(including)
7.51.0
运行在以下环境
系统 alpine_3.2 curl * Up to
(excluding)
7.52.1-r0
运行在以下环境
系统 alpine_3.3 curl * Up to
(excluding)
7.52.1-r0
阿里云评分
6.9
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    N/A
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况