低危 Google Go 1.6.3/1.7.3 net-http RequestParseMultipartForm File Descriptor 拒绝服务漏洞

CVE编号

CVE-2017-1000098

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-10-05
漏洞描述
Google Golang Go是美国谷歌(Google)公司的一种针对多处理器系统应用程序的编程进行了优化的编程语言。

Google Golang Go 1.7.3版本和1.6.3版本中存在安全漏洞。攻击者可通过发送特制的请求利用该漏洞造成拒绝服务(文件描述符耗尽)。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://groups.google.com/forum/#%21msg/golang-dev/4NdLzS8sls8/uIz8QlnIBQAJ
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 golang go 1.6.3 -
运行在以下环境
应用 golang go 1.7.3 -
运行在以下环境
系统 debian_7 golang * Up to
(excluding)
2:1.0.2-1.1+deb7u1
运行在以下环境
系统 redhat_7 golang * Up to
(excluding)
0:1.8.3-1.el7
运行在以下环境
系统 ubuntu_18.04.5_lts golang-1.8 * Up to
(excluding)
1.8.3-2ubuntu1
运行在以下环境
系统 ubuntu_18.10 golang-1.7 * Up to
(excluding)
1.7.4-2ubuntu1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
阿里云安全产品覆盖情况