低危 libffi任意代码执行

CVE编号

CVE-2017-1000381

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-07-08 06:29:00
漏洞描述
如果传递的dns响应数据包是以特定方式编制的,则可以触发cares函数“aresparsenaptrreply()”(用于分析naptr响应),以在给定输入缓冲区之外读取内存。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://c-ares.haxx.se/adv_20170620.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 c-ares_project c-ares 1.10.0 -
运行在以下环境
应用 c-ares_project c-ares 1.11.0 -
运行在以下环境
应用 c-ares_project c-ares 1.12.0 -
运行在以下环境
应用 c-ares_project c-ares 1.8.0 -
运行在以下环境
应用 c-ares_project c-ares 1.9.0 -
运行在以下环境
应用 c-ares_project c-ares 1.9.1 -
运行在以下环境
系统 alpine_3.10 nodejs * Up to
(excluding)
6.11.1-r0
运行在以下环境
系统 alpine_3.11 nodejs * Up to
(excluding)
6.11.1-r0
运行在以下环境
系统 alpine_3.12 nodejs * Up to
(excluding)
6.11.1-r0
运行在以下环境
系统 alpine_3.13 nodejs * Up to
(excluding)
6.11.1-r0
运行在以下环境
系统 alpine_3.14 nodejs * Up to
(excluding)
6.11.1-r0
运行在以下环境
系统 alpine_3.15 nodejs * Up to
(excluding)
6.11.1-r0
运行在以下环境
系统 alpine_3.3 nodejs * Up to
(excluding)
1.12.0-r1
运行在以下环境
系统 alpine_3.4 nodejs * Up to
(excluding)
6.7.0-r1
运行在以下环境
系统 alpine_3.5 nodejs * Up to
(excluding)
1.12.0-r1
运行在以下环境
系统 alpine_3.6 nodejs * Up to
(excluding)
1.12.0-r1
运行在以下环境
系统 alpine_3.7 nodejs * Up to
(excluding)
6.11.1-r0
运行在以下环境
系统 alpine_3.8 nodejs * Up to
(excluding)
6.11.1-r0
运行在以下环境
系统 alpine_3.9 nodejs * Up to
(excluding)
6.11.1-r0
运行在以下环境
系统 alpine_edge nodejs * Up to
(excluding)
6.11.1-r0
运行在以下环境
系统 amazon_AMI nodejs * Up to
(excluding)
1.13.0-1.5.amzn1
运行在以下环境
系统 debian_7 nodejs * Up to
(excluding)
1.9.1-3+deb7u2
运行在以下环境
系统 debian_8 nodejs * Up to
(excluding)
1.10.0-2+deb8u2
运行在以下环境
系统 debian_9 nodejs * Up to
(excluding)
1.12.0-1+deb9u1
运行在以下环境
系统 fedora_24 nodejs * Up to
(excluding)
1.13.0-1.fc24
运行在以下环境
系统 fedora_25 nodejs * Up to
(excluding)
1.13.0-1.fc25
运行在以下环境
系统 fedora_26 nodejs * Up to
(excluding)
1.13.0-1.fc26
运行在以下环境
系统 fedora_EPEL_7 nodejs * Up to
(excluding)
1.13.0-1.el7
运行在以下环境
系统 opensuse_Leap_42.2 nodejs * Up to
(excluding)
1.9.1-8.3.1
运行在以下环境
系统 opensuse_Leap_42.3 nodejs * Up to
(excluding)
6.11.1-3.1
运行在以下环境
系统 suse_12_SP2 nodejs * Up to
(excluding)
1.9.1-8.1
运行在以下环境
系统 ubuntu_16.04 nodejs * Up to
(excluding)
1.10.0-3ubuntu0.2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-200 信息暴露
阿里云安全产品覆盖情况