低危 Bro 至 2.5.1 ContentLine Analyzer 越界写入漏洞

CVE编号

CVE-2017-1000458

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-01-03 07:29:00
漏洞描述
Bro是The Bro项目的一款开源网络安全监控软件。ContentLine analyzer是其中的一个内容分析器。

Bro 2.5.2之前的版本中的ContentLine analyzer存在安全漏洞。远程攻击者可利用该漏洞造成拒绝服务(越边界写入和崩溃)。
解决建议
目前厂商已发布漏洞修复程序,请及时关注更新:
https://github.com/bro/bro/commit/6c0f101a62489b1c5927b4ed63b0e1d37db40282
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 bro bro 2.5.2 -
运行在以下环境
系统 debian_9 bro * Up to
(excluding)
2.5-1
运行在以下环境
系统 fedora_26 bro * Up to
(excluding)
2.5.3-1.fc26
运行在以下环境
系统 fedora_27 bro * Up to
(excluding)
2.5.3-1.fc27
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况