低危 代码执行目录遍历

CVE编号

CVE-2017-1000501

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-01-04 04:29:00
漏洞描述
Awstats 7.6及更早版本在处理'config'和'migrate'参数时容易受到路径遍历缺陷的影响,从而导致未经身份验证的远程代码执行。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/eldy/awstats/commit/06c0ab29c1e5059d9e0279c6b64d573d619e1651
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 awstats awstats * Up to
(including)
7.6.0
2
运行在以下环境
系统 alpine_3.9 awstats * Up to
(excluding)
7.6-r2
3
运行在以下环境
系统 alpine_3.6 awstats * Up to
(excluding)
7.6-r1
4
运行在以下环境
系统 fedora_EPEL_7 awstats * Up to
(excluding)
7.6-4.el7
5
运行在以下环境
系统 fedora_26 awstats * Up to
(excluding)
7.6-4.fc26
6
运行在以下环境
系统 fedora_27 awstats * Up to
(excluding)
7.6-8.fc27
7
运行在以下环境
系统 alpine_3.4 awstats * Up to
(excluding)
7.5-r2
8
运行在以下环境
系统 alpine_3.11 awstats * Up to
(excluding)
7.6-r2
9
运行在以下环境
系统 alpine_3.13 awstats * Up to
(excluding)
7.6-r2
10
运行在以下环境
系统 alpine_3.12 awstats * Up to
(excluding)
7.6-r2
11
运行在以下环境
系统 alpine_3.5 awstats * Up to
(excluding)
7.5-r2
12
运行在以下环境
系统 alpine_3.7 awstats * Up to
(excluding)
7.6-r2
13
运行在以下环境
系统 alpine_3.10 awstats * Up to
(excluding)
7.6-r2
14
运行在以下环境
系统 alpine_3.8 awstats * Up to
(excluding)
7.6-r2
15
运行在以下环境
系统 debian_9 awstats * Up to
(excluding)
7.6+dfsg-1+deb9u1
16
运行在以下环境
系统 debian_8 awstats * Up to
(excluding)
7.2+dfsg-1+deb8u1
17
运行在以下环境
系统 debian_7 awstats * Up to
(excluding)
7.0~dfsg-7+deb7u1
18
运行在以下环境
系统 alpine_edge awstats * Up to
(excluding)
7.6-r2
19
运行在以下环境
系统 ubuntu_16.04 awstats * Up to
(excluding)
7.4+dfsg-1ubuntu0.2
20
运行在以下环境
系统 fedora_EPEL_7 awstats * Up to
(excluding)
7.6-4.el7
21
运行在以下环境
系统 alpine_3.14 awstats * Up to
(excluding)
7.6-r2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-22 对路径名的限制不恰当(路径遍历)
阿里云安全产品覆盖情况