低危 Puppet Agent全局可写模块漏洞

CVE编号

CVE-2017-10689

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-02-10
漏洞描述
Puppet是美国Puppet实验室的一套基于客户端/服务器(C/S)架构的配置管理工具。Puppet Agent是其中的一个代理。

Puppet Agent 5.3.4之前版本和1.10.10之前版本中存在安全漏洞。攻击者可利用该漏洞为安装的模块分配全局可写入权限。
解决建议
厂商已发布漏洞修复程序,请及时关注更新:
https://puppet.com/security/cve/CVE-2017-10689
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 puppet puppet * Up to
(excluding)
5.3.4
运行在以下环境
应用 puppet puppet * From
(including)
1.10.0
Up to
(excluding)
1.10.10
运行在以下环境
应用 puppet puppet_enterprise * Up to
(excluding)
2016.4.10
运行在以下环境
应用 puppet puppet_enterprise * From
(including)
2017.1.0
Up to
(excluding)
2017.3.4
运行在以下环境
应用 redhat satellite 6.4 -
运行在以下环境
系统 debian_9 puppet * Up to
(including)
4.8.2-5
运行在以下环境
系统 fedora_27 puppet * Up to
(excluding)
4.10.10-1.fc27
运行在以下环境
系统 fedora_28 puppet * Up to
(excluding)
4.10.10-1.fc28
运行在以下环境
系统 opensuse_Leap_42.3 puppet * Up to
(excluding)
3.8.7-23.1
运行在以下环境
系统 suse_12 puppet * Up to
(excluding)
3.8.5-15.9
运行在以下环境
系统 suse_12_SP2 puppet * Up to
(excluding)
3.8.5-15.9.1
运行在以下环境
系统 suse_12_SP3 puppet * Up to
(excluding)
3.8.5-15.9.1
运行在以下环境
系统 ubuntu_14.04 puppet * Up to
(excluding)
3.4.3-1ubuntu1.3
运行在以下环境
系统 ubuntu_14.04.6_lts puppet * Up to
(excluding)
3.4.3-1ubuntu1.3
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-269 特权管理不恰当
阿里云安全产品覆盖情况