IBM Campaign 9.1/9.1.2/10 Web UI 跨站脚本攻击

CVE编号

CVE-2017-1114

利用情况

暂无

补丁情况

N/A

披露时间

2018-09-08
漏洞描述
IBM Campaign(前称Unica Campaign)是美国IBM公司的一套用于帮助营销人员设计、执行、衡量和优化营销广告的管理解决方案。

IBM Campaign 9.1版本、9.1.2版本和10版本中存在跨站脚本漏洞,远程攻击者可利用该漏洞向Web UI中注入任意的JavaScript代码。
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://www.ibm.com/support/docview.wss?uid=ibm10729773
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 ibm campaign 10.0 -
运行在以下环境
应用 ibm campaign 9.1 -
运行在以下环境
应用 ibm campaign 9.1.2 -
运行在以下环境
系统 alpine_3.10 php5 * Up to
(excluding)
1.3.27-r0
运行在以下环境
系统 alpine_3.11 php5 * Up to
(excluding)
1.3.27-r0
运行在以下环境
系统 alpine_3.12 php5 * Up to
(excluding)
1.3.27-r0
运行在以下环境
系统 alpine_3.13 php5 * Up to
(excluding)
1.3.27-r0
运行在以下环境
系统 alpine_edge php5 * Up to
(excluding)
1.3.27-r0
运行在以下环境
系统 amazon linux_AMI php5 * Up to
(excluding)
1.3.28-1.12.amzn1
运行在以下环境
系统 amazon_AMI GraphicsMagick * Up to
(excluding)
1.3.28-1.12.amzn1
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0
运行在以下环境
系统 debian_7 php5 * Up to
(excluding)
1.3.16-1.1+deb7u8
运行在以下环境
系统 debian_8 php5 * Up to
(excluding)
1.3.20-3+deb8u2
运行在以下环境
系统 debian_9 php5 * Up to
(excluding)
1.3.30+hg15796-1~deb9u1
运行在以下环境
系统 fedora_25 php5 * Up to
(excluding)
0.31.1-49.fc25
运行在以下环境
系统 fedora_26 php5 * Up to
(excluding)
0.31.1-49.fc26
运行在以下环境
系统 fedora_27 php5 * Up to
(excluding)
1.3.28-1.fc27
运行在以下环境
系统 fedora_EPEL_6 php5 * Up to
(excluding)
1.3.28-1.el6
运行在以下环境
系统 fedora_EPEL_7 php5 * Up to
(excluding)
1.3.28-1.el7
运行在以下环境
系统 opensuse_Leap_42.2 php5 * Up to
(excluding)
6.8.8.1-49.1
运行在以下环境
系统 opensuse_Leap_42.3 php5 * Up to
(excluding)
1.3.25-68.1
运行在以下环境
系统 sles_11_SP4 php5 * Up to
(excluding)
6.4.3.6-7.78.22.1
运行在以下环境
系统 sles_12 apache2-mod_php5 * Up to
(excluding)
5.5.14-109.5
运行在以下环境
系统 sles_12_SP2 php5 * Up to
(excluding)
1-6.8.8.1-71.26.1
运行在以下环境
系统 sles_12_SP3 php5 * Up to
(excluding)
1-6.8.8.1-71.26.1
运行在以下环境
系统 suse_11_SP4 GraphicsMagick * Up to
(excluding)
6.4.3.6-7.78.22.1
运行在以下环境
系统 suse_12 apache2-mod_php5 * Up to
(excluding)
5.5.14-109.5
运行在以下环境
系统 suse_12_SP2 GraphicsMagick * Up to
(excluding)
1-6.8.8.1-71.26.1
运行在以下环境
系统 suse_12_SP3 GraphicsMagick * Up to
(excluding)
1-6.8.8.1-71.26.1
运行在以下环境
系统 ubuntu_14.04.6_lts php5 * Up to
(excluding)
5.5.9+dfsg-1ubuntu4.22
运行在以下环境
系统 ubuntu_14.04_lts php5 * Up to
(excluding)
5.5.9+dfsg-1ubuntu4.22
运行在以下环境
系统 ubuntu_16.04.7_lts php7.0 * Up to
(excluding)
7.0.22-0ubuntu0.16.04.1
运行在以下环境
系统 ubuntu_18.04.5_lts graphicsmagick * Up to
(excluding)
1.3.26-3
运行在以下环境
系统 ubuntu_18.04_lts graphicsmagick * Up to
(excluding)
1.3.26-3
运行在以下环境
系统 ubuntu_18.10 graphicsmagick * Up to
(excluding)
1.3.26-3
CVSS3评分
5.4
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    已更改
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况