低危 ImageMagick UAF拒绝服务

CVE编号

CVE-2017-12431

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-08-04
漏洞描述
在ImageMagick 7.0.6-1中,在coders / wmf.c中的函数ReadWMFImage中发现了一个UAF的漏洞,它允许攻击者导致拒绝服务。

解决建议
厂商已发布漏洞修复程序,请及时关注更新:
http://www.imagemagick.org/download/beta/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 imagemagick imagemagick 7.0.6-1 -
运行在以下环境
系统 debian_7 imagemagick * Up to
(excluding)
8:6.7.7.10-5+deb7u16
运行在以下环境
系统 debian_8 imagemagick * Up to
(excluding)
8:6.8.9.9-5+deb8u2
运行在以下环境
系统 debian_9 imagemagick * Up to
(excluding)
8:6.9.7.4+dfsg-11+deb9u2
运行在以下环境
系统 opensuse_Leap_42.2 imagemagick * Up to
(excluding)
1-6.8.8.1-37.1
运行在以下环境
系统 opensuse_Leap_42.3 imagemagick * Up to
(excluding)
1-6.8.8.1-37.1
运行在以下环境
系统 suse_12 ImageMagick * Up to
(excluding)
6.8.8.1-71.12
运行在以下环境
系统 suse_12_SP2 imagemagick * Up to
(excluding)
6.8.8.1-71.12.1
运行在以下环境
系统 suse_12_SP3 imagemagick * Up to
(excluding)
6.8.8.1-71.12.1
运行在以下环境
系统 ubuntu_14.04.6_lts imagemagick * Up to
(excluding)
8:6.7.7.10-6ubuntu3.11
运行在以下环境
系统 ubuntu_16.04 imagemagick * Up to
(excluding)
8:6.8.9.9-7ubuntu5.11
运行在以下环境
系统 ubuntu_16.04.7_lts imagemagick * Up to
(excluding)
8:6.8.9.9-7ubuntu5.11
运行在以下环境
系统 ubuntu_18.04.5_lts imagemagick * Up to
(excluding)
8:6.9.7.4+dfsg-16ubuntu2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-416 释放后使用
阿里云安全产品覆盖情况