低危 GNU Binutils '_bfd_vms_slurp_egsd'函数任意内存读取漏洞

CVE编号

CVE-2017-12454

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-08-05 04:29:00
漏洞描述
GNU Binutils(又名GNU Binary Utilities或binutils)是GNU计划开发的一组编程语言工具程序,它主要用于处理多种格式的目标文件,并提供有连接器、汇编器和其他用于目标文件和档案的工具。Binary File Descriptor(BFD)library(又名libbfd)是其中的一个以各种格式便携式操作对象文件的库。
GNU Binutils 2.29及之前的版本中的BFD库的bfd/vms-alpha.c文件的'_bfd_vms_slurp_egsd'函数存在安全漏洞。远程攻击者可借助特制的vms alpha文件利用该漏洞读取任意内存。
解决建议
厂商已发布漏洞修复程序,请及时关注更新:
https://sourceware.org/bugzilla/show_bug.cgi?id=21813
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu binutils * Up to
(including)
2.29
2
运行在以下环境
系统 suse_12_SP2 binutils * Up to
(excluding)
2.29.1-9.20.2
3
运行在以下环境
系统 suse_12_SP3 binutils * Up to
(excluding)
2.29.1-9.20.2
4
运行在以下环境
系统 amazon_2 binutils * Up to
(excluding)
2.29.1-27.amzn2.0.1
5
运行在以下环境
系统 debian_9 binutils * Up to
(excluding)
2.28-5
6
运行在以下环境
系统 fedora_29 binutils * Up to
(excluding)
2.31.1-17.fc29
7
运行在以下环境
系统 opensuse_Leap_42.2 binutils * Up to
(excluding)
2.29.1-13.1
8
运行在以下环境
系统 opensuse_Leap_42.3 binutils * Up to
(excluding)
2.29.1-13.1
9
运行在以下环境
系统 ubuntu_16.04 binutils * Up to
(excluding)
2.26.1-1ubuntu1~16.04.8+esm1
10
运行在以下环境
系统 suse_12_SP2 binutils * Up to
(excluding)
2.29.1-9.20.2
11
运行在以下环境
系统 suse_12_SP3 binutils * Up to
(excluding)
2.29.1-9.20.2
12
运行在以下环境
系统 suse_12_SP2 binutils * Up to
(excluding)
2.29.1-9.20.2
13
运行在以下环境
系统 suse_12_SP3 binutils * Up to
(excluding)
2.29.1-9.20.2
14
运行在以下环境
系统 opensuse_Leap_42.2 binutils * Up to
(excluding)
2.29.1-13.1
15
运行在以下环境
系统 opensuse_Leap_42.3 binutils * Up to
(excluding)
2.29.1-13.1
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况