中危 Apache Portable Runtime拒绝服务漏洞

CVE编号

CVE-2017-12618

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-10-24
漏洞描述
Apache Portable Runtime Utility(APR-util)是美国阿帕奇(Apache)软件基金会的一个为上层应用程序提供可跨越多个操作系统平台使用的底层支持接口实用程序。

Apache Portable Runtime Utility (APR-util)1.6.0及之前的版本中存在安全漏洞,该漏洞源于程序未能验证‘apr_sdbm*()’函数使用的SDBM数据库文件的完整性。本地攻击者可利用该漏洞造成拒绝服务(越边界读取和崩溃)。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
http://mail-archives.apache.org/mod_mbox/apr-dev/201710.mbox/%3CCACsi252POs4toeJJciwg09_eu2cO3XFg%3DUqsPjXsfjDoeC3-UQ%40mail.gmail.com%3E
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache portable_runtime_utility 0.9.1 -
运行在以下环境
应用 apache portable_runtime_utility 0.9.10 -
运行在以下环境
应用 apache portable_runtime_utility 0.9.11 -
运行在以下环境
应用 apache portable_runtime_utility 0.9.12 -
运行在以下环境
应用 apache portable_runtime_utility 0.9.13 -
运行在以下环境
应用 apache portable_runtime_utility 0.9.14 -
运行在以下环境
应用 apache portable_runtime_utility 0.9.15 -
运行在以下环境
应用 apache portable_runtime_utility 0.9.16 -
运行在以下环境
应用 apache portable_runtime_utility 0.9.17 -
运行在以下环境
应用 apache portable_runtime_utility 0.9.18 -
运行在以下环境
应用 apache portable_runtime_utility 0.9.19 -
运行在以下环境
应用 apache portable_runtime_utility 0.9.2 -
运行在以下环境
应用 apache portable_runtime_utility 0.9.20 -
运行在以下环境
应用 apache portable_runtime_utility 0.9.3 -
运行在以下环境
应用 apache portable_runtime_utility 0.9.4 -
运行在以下环境
应用 apache portable_runtime_utility 0.9.5 -
运行在以下环境
应用 apache portable_runtime_utility 0.9.6 -
运行在以下环境
应用 apache portable_runtime_utility 0.9.7 -
运行在以下环境
应用 apache portable_runtime_utility 0.9.9 -
运行在以下环境
应用 apache portable_runtime_utility 1.0.0 -
运行在以下环境
应用 apache portable_runtime_utility 1.0.1 -
运行在以下环境
应用 apache portable_runtime_utility 1.0.2 -
运行在以下环境
应用 apache portable_runtime_utility 1.1.0 -
运行在以下环境
应用 apache portable_runtime_utility 1.1.1 -
运行在以下环境
应用 apache portable_runtime_utility 1.1.2 -
运行在以下环境
应用 apache portable_runtime_utility 1.2.1 -
运行在以下环境
应用 apache portable_runtime_utility 1.2.10 -
运行在以下环境
应用 apache portable_runtime_utility 1.2.12 -
运行在以下环境
应用 apache portable_runtime_utility 1.2.13 -
运行在以下环境
应用 apache portable_runtime_utility 1.2.2 -
运行在以下环境
应用 apache portable_runtime_utility 1.2.6 -
运行在以下环境
应用 apache portable_runtime_utility 1.2.7 -
运行在以下环境
应用 apache portable_runtime_utility 1.2.8 -
运行在以下环境
应用 apache portable_runtime_utility 1.2.9 -
运行在以下环境
应用 apache portable_runtime_utility 1.3.0 -
运行在以下环境
应用 apache portable_runtime_utility 1.3.1 -
运行在以下环境
应用 apache portable_runtime_utility 1.3.10 -
运行在以下环境
应用 apache portable_runtime_utility 1.3.11 -
运行在以下环境
应用 apache portable_runtime_utility 1.3.12 -
运行在以下环境
应用 apache portable_runtime_utility 1.3.13 -
运行在以下环境
应用 apache portable_runtime_utility 1.3.2 -
运行在以下环境
应用 apache portable_runtime_utility 1.3.3 -
运行在以下环境
应用 apache portable_runtime_utility 1.3.4 -
运行在以下环境
应用 apache portable_runtime_utility 1.3.5 -
运行在以下环境
应用 apache portable_runtime_utility 1.3.6 -
运行在以下环境
应用 apache portable_runtime_utility 1.3.7 -
运行在以下环境
应用 apache portable_runtime_utility 1.3.8 -
运行在以下环境
应用 apache portable_runtime_utility 1.3.9 -
运行在以下环境
应用 apache portable_runtime_utility 1.4.0 -
运行在以下环境
应用 apache portable_runtime_utility 1.4.1 -
运行在以下环境
应用 apache portable_runtime_utility 1.4.2 -
运行在以下环境
应用 apache portable_runtime_utility 1.4.3 -
运行在以下环境
应用 apache portable_runtime_utility 1.5.0 -
运行在以下环境
应用 apache portable_runtime_utility 1.5.1 -
运行在以下环境
应用 apache portable_runtime_utility 1.5.2 -
运行在以下环境
应用 apache portable_runtime_utility 1.5.3 -
运行在以下环境
应用 apache portable_runtime_utility 1.5.4 -
运行在以下环境
应用 apache portable_runtime_utility 1.5.5 -
运行在以下环境
应用 apache portable_runtime_utility 1.6.0 -
运行在以下环境
系统 amazon_AMI apr-util * Up to
(excluding)
1.5.4-6.18.amzn1
运行在以下环境
系统 debian_7 apr-util * Up to
(excluding)
1.4.1-3+deb7u1
运行在以下环境
系统 debian_9 apr-util * Up to
(excluding)
1.5.4-3
运行在以下环境
系统 fedora_25 apr-util * Up to
(excluding)
1.5.4-4.fc25
运行在以下环境
系统 fedora_26 apr-util * Up to
(excluding)
1.5.4-6.fc26
运行在以下环境
系统 opensuse_Leap_42.2 apr-util * Up to
(excluding)
1.5.3-8.1
运行在以下环境
系统 opensuse_Leap_42.3 apr-util * Up to
(excluding)
1.5.3-8.1
运行在以下环境
系统 suse_11_SP4 apr-util * Up to
(excluding)
1.3.4-12.22.23.3.2
运行在以下环境
系统 suse_12_SP2 apr-util * Up to
(excluding)
1.5.3-2.3.1
运行在以下环境
系统 suse_12_SP3 apr-util * Up to
(excluding)
1.5.3-2.3.1
阿里云评分
5.2
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况