中危 ImageMagick 至 7.0.6-5 enhance.c 内存破坏漏洞

CVE编号

CVE-2017-12876

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-08-29
漏洞描述
ImageMagick是美国ImageMagick Studio公司的一套开源的图象处理软件。该软件可读取、转换、写入多种格式的图片。

ImageMagick 7.0.6-6之前的版本中的enhance.c文件存在堆缓冲区溢出漏洞。远程攻击者可借助特制的文件利用该漏洞造成拒绝服务。
解决建议
厂商已发布漏洞修复程序,请及时关注更新:
https://github.com/ImageMagick/ImageMagick/commit/1cc6f0ccc92c20c7cab6c4a7335daf29c91f0d8e
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 imagemagick imagemagick * Up to
(including)
7.0.6-5
阿里云评分
5.9
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
CWE-787 跨界内存写
阿里云安全产品覆盖情况