中危 WPA2无线网络STK密钥重装漏洞

CVE编号

CVE-2017-13084

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-10-18
漏洞描述
WPA(Wi-Fi Protected Access)是一种保护无线电脑网络(Wi-Fi)安全的系统。

WPA2无线网络在PeerKey握手中存在组密钥重装漏洞。漏洞是由于Wi-Fi保护访问II(WPA2)握手流量可以被操纵以引起随机数和会话密钥重用,导致无线接入点(AP)或客户端重新安装密钥。攻击者利用漏洞攻击可能包括任意数据包解密和注入,TCP连接劫持,HTTP内容注入或单播和组寻址帧的重放。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,详情请关注厂商主页:
https://www.wi-fi.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 w1.fi hostapd 0.2.4 -
运行在以下环境
应用 w1.fi hostapd 0.2.5 -
运行在以下环境
应用 w1.fi hostapd 0.2.6 -
运行在以下环境
应用 w1.fi hostapd 0.2.8 -
运行在以下环境
应用 w1.fi hostapd 0.3.10 -
运行在以下环境
应用 w1.fi hostapd 0.3.11 -
运行在以下环境
应用 w1.fi hostapd 0.3.7 -
运行在以下环境
应用 w1.fi hostapd 0.3.9 -
运行在以下环境
应用 w1.fi hostapd 0.4.10 -
运行在以下环境
应用 w1.fi hostapd 0.4.11 -
运行在以下环境
应用 w1.fi hostapd 0.4.7 -
运行在以下环境
应用 w1.fi hostapd 0.4.8 -
运行在以下环境
应用 w1.fi hostapd 0.4.9 -
运行在以下环境
应用 w1.fi hostapd 0.5.10 -
运行在以下环境
应用 w1.fi hostapd 0.5.11 -
运行在以下环境
应用 w1.fi hostapd 0.5.7 -
运行在以下环境
应用 w1.fi hostapd 0.5.8 -
运行在以下环境
应用 w1.fi hostapd 0.5.9 -
运行在以下环境
应用 w1.fi hostapd 0.6.10 -
运行在以下环境
应用 w1.fi hostapd 0.6.8 -
运行在以下环境
应用 w1.fi hostapd 0.6.9 -
运行在以下环境
应用 w1.fi hostapd 0.7.3 -
运行在以下环境
应用 w1.fi hostapd 1.0 -
运行在以下环境
应用 w1.fi hostapd 1.1 -
运行在以下环境
应用 w1.fi hostapd 2.0 -
运行在以下环境
应用 w1.fi hostapd 2.1 -
运行在以下环境
应用 w1.fi hostapd 2.2 -
运行在以下环境
应用 w1.fi hostapd 2.3 -
运行在以下环境
应用 w1.fi hostapd 2.4 -
运行在以下环境
应用 w1.fi hostapd 2.5 -
运行在以下环境
应用 w1.fi hostapd 2.6 -
运行在以下环境
应用 w1.fi wpa_supplicant 0.2.4 -
运行在以下环境
应用 w1.fi wpa_supplicant 0.2.5 -
运行在以下环境
应用 w1.fi wpa_supplicant 0.2.6 -
运行在以下环境
应用 w1.fi wpa_supplicant 0.2.7 -
运行在以下环境
应用 w1.fi wpa_supplicant 0.2.8 -
运行在以下环境
应用 w1.fi wpa_supplicant 0.3.10 -
运行在以下环境
应用 w1.fi wpa_supplicant 0.3.11 -
运行在以下环境
应用 w1.fi wpa_supplicant 0.3.7 -
运行在以下环境
应用 w1.fi wpa_supplicant 0.3.8 -
运行在以下环境
应用 w1.fi wpa_supplicant 0.3.9 -
运行在以下环境
应用 w1.fi wpa_supplicant 0.4.10 -
运行在以下环境
应用 w1.fi wpa_supplicant 0.4.11 -
运行在以下环境
应用 w1.fi wpa_supplicant 0.4.7 -
运行在以下环境
应用 w1.fi wpa_supplicant 0.4.8 -
运行在以下环境
应用 w1.fi wpa_supplicant 0.4.9 -
运行在以下环境
应用 w1.fi wpa_supplicant 0.5.10 -
运行在以下环境
应用 w1.fi wpa_supplicant 0.5.11 -
运行在以下环境
应用 w1.fi wpa_supplicant 0.5.7 -
运行在以下环境
应用 w1.fi wpa_supplicant 0.5.8 -
运行在以下环境
应用 w1.fi wpa_supplicant 0.5.9 -
运行在以下环境
应用 w1.fi wpa_supplicant 0.6.10 -
运行在以下环境
应用 w1.fi wpa_supplicant 0.6.8 -
运行在以下环境
应用 w1.fi wpa_supplicant 0.6.9 -
运行在以下环境
应用 w1.fi wpa_supplicant 0.7.3 -
运行在以下环境
应用 w1.fi wpa_supplicant 1.0 -
运行在以下环境
应用 w1.fi wpa_supplicant 1.1 -
运行在以下环境
应用 w1.fi wpa_supplicant 2.0 -
运行在以下环境
应用 w1.fi wpa_supplicant 2.1 -
运行在以下环境
应用 w1.fi wpa_supplicant 2.2 -
运行在以下环境
应用 w1.fi wpa_supplicant 2.3 -
运行在以下环境
应用 w1.fi wpa_supplicant 2.4 -
运行在以下环境
应用 w1.fi wpa_supplicant 2.5 -
运行在以下环境
应用 w1.fi wpa_supplicant 2.6 -
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 canonical ubuntu_linux 17.04 -
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 debian debian_linux 9.0 -
运行在以下环境
系统 debian_10 wpa * Up to
(including)
2.7+git20190128+0c1e29f-6+deb10u3
运行在以下环境
系统 debian_11 wpa * Up to
(including)
2.9.0-21
运行在以下环境
系统 debian_12 wpa * Up to
(including)
2.10-9
运行在以下环境
系统 debian_9 wpa * Up to
(including)
2.4-1+deb9u6
运行在以下环境
系统 debian_sid wpa * Up to
(including)
2.10-9
运行在以下环境
系统 freebsd freebsd * -
运行在以下环境
系统 freebsd freebsd 10 -
运行在以下环境
系统 freebsd freebsd 10.4 -
运行在以下环境
系统 freebsd freebsd 11 -
运行在以下环境
系统 freebsd freebsd 11.1 -
运行在以下环境
系统 opensuse leap 42.2 -
运行在以下环境
系统 opensuse leap 42.3 -
运行在以下环境
系统 redhat enterprise_linux_desktop 7 -
运行在以下环境
系统 redhat enterprise_linux_server 7 -
运行在以下环境
系统 suse linux_enterprise_desktop 12 -
运行在以下环境
系统 suse linux_enterprise_point_of_sale 11 -
运行在以下环境
系统 suse linux_enterprise_server 11 -
运行在以下环境
系统 suse linux_enterprise_server 12 -
运行在以下环境
系统 suse openstack_cloud 6 -
阿里云评分
6.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    N/A
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-330 使用不充分的随机数
阿里云安全产品覆盖情况