IBM RELM 4.0/5.0/6.0 Web UI 跨站脚本攻击

CVE编号

CVE-2017-1364

利用情况

暂无

补丁情况

N/A

披露时间

2017-10-03
漏洞描述
IBM Rational Engineering Lifecycle Manager(RELM)是美国IBM公司的一套工程生命周期管理软件。

IBM RELM中存在跨站脚本漏洞。远程攻击者可利用该漏洞在Web UI中注入任意的JavaScript代码。

解决建议
厂商已发布漏洞修复程序,请及时关注更新:
http://www-01.ibm.com/support/docview.wss?uid=swg22008785
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 ibm rational_engineering_lifecycle_manager 4.0.3 -
运行在以下环境
应用 ibm rational_engineering_lifecycle_manager 4.0.4 -
运行在以下环境
应用 ibm rational_engineering_lifecycle_manager 4.0.5 -
运行在以下环境
应用 ibm rational_engineering_lifecycle_manager 4.0.6 -
运行在以下环境
应用 ibm rational_engineering_lifecycle_manager 4.0.7 -
运行在以下环境
应用 ibm rational_engineering_lifecycle_manager 5.0.0 -
运行在以下环境
应用 ibm rational_engineering_lifecycle_manager 5.0.1 -
运行在以下环境
应用 ibm rational_engineering_lifecycle_manager 5.0.2 -
运行在以下环境
应用 ibm rational_engineering_lifecycle_manager 6.0.0 -
运行在以下环境
应用 ibm rational_engineering_lifecycle_manager 6.0.1 -
运行在以下环境
应用 ibm rational_engineering_lifecycle_manager 6.0.2 -
运行在以下环境
应用 ibm rational_engineering_lifecycle_manager 6.0.3 -
运行在以下环境
应用 ibm rational_engineering_lifecycle_manager 6.0.4 -
运行在以下环境
系统 alpine_3.10 sox * Up to
(excluding)
14.4.2-r5
运行在以下环境
系统 alpine_3.11 sox * Up to
(excluding)
14.4.2-r5
运行在以下环境
系统 alpine_3.12 sox * Up to
(excluding)
14.4.2-r5
运行在以下环境
系统 alpine_3.13 sox * Up to
(excluding)
14.4.2-r5
运行在以下环境
系统 alpine_3.9 sox * Up to
(excluding)
1.3.26-r5
运行在以下环境
系统 alpine_edge sox * Up to
(excluding)
14.4.2-r5
运行在以下环境
系统 fedora_29 sox * Up to
(excluding)
1.3.32-1.fc29
运行在以下环境
系统 fedora_30 sox * Up to
(excluding)
1.3.32-1.fc30
运行在以下环境
系统 fedora_EPEL_7 sox * Up to
(excluding)
1.3.34-1.el7
运行在以下环境
系统 fedora_EPEL_8 sox * Up to
(excluding)
1.3.34-1.el8
运行在以下环境
系统 opensuse_Leap_42.2 sox * Up to
(excluding)
1.3.25-57.1
运行在以下环境
系统 opensuse_Leap_42.3 sox * Up to
(excluding)
1.3.25-57.1
运行在以下环境
系统 sles_11_SP4 sox * Up to
(excluding)
6.4.3.6-7.78.22.1
运行在以下环境
系统 sles_12 ImageMagick * Up to
(excluding)
6.8.8.1-71.26
运行在以下环境
系统 sles_12_SP2 sox * Up to
(excluding)
1-6.8.8.1-71.26.1
运行在以下环境
系统 sles_12_SP3 sox * Up to
(excluding)
1-6.8.8.1-71.26.1
运行在以下环境
系统 suse_11_SP4 libMagickCore1-32bit * Up to
(excluding)
6.4.3.6-7.78.22.1
运行在以下环境
系统 suse_12 ImageMagick * Up to
(excluding)
6.8.8.1-71.26
运行在以下环境
系统 suse_12_SP2 libMagickCore1-32bit * Up to
(excluding)
1-6.8.8.1-71.26.1
运行在以下环境
系统 suse_12_SP3 libMagickCore1-32bit * Up to
(excluding)
1-6.8.8.1-71.26.1
CVSS3评分
5.4
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    已更改
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况