低危 LibreOffice libwpd拒绝服务漏洞

CVE编号

CVE-2017-14226

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-09-09
漏洞描述
LibreOffice是文档基金会(The Document Foundation,TDF)开发的一套免费开源的办公软件套件。该套件由Writer(文本文档)、Calc(电子表格)和Impress(演示文稿)等应用程序组成。libwpd是其中的一个用于读取和转换Word Perfect文档的函数库。

LibreOffice 5.3.7之前的版本中的libwpd 0.10.1版本的WP1StylesListener.cpp、WP5StylesListener.cpp和WP42StylesListener.cpp文件存在安全漏洞,该漏洞源于程序未能正确的处理迭代器。远程攻击者可利用该漏洞造成拒绝服务(WPXTable.cpp文件的WPXTableList类堆缓冲区越边界读取)。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://sourceforge.net/p/libwpd/tickets/14/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libreoffice libreoffice * Up to
(including)
5.3.6
运行在以下环境
应用 libwpd libwpd 0.10.1 -
运行在以下环境
系统 debian_8 libwpd * Up to
(excluding)
0.10.0-2+deb8u1
运行在以下环境
系统 debian_9 libwpd * Up to
(excluding)
0.10.1-5+deb9u1
运行在以下环境
系统 fedora_25 libwpd * Up to
(excluding)
0.10.2-1.fc25
运行在以下环境
系统 fedora_26 libwpd * Up to
(excluding)
0.10.2-1.fc26
运行在以下环境
系统 fedora_27 libwpd * Up to
(excluding)
0.10.2-1.fc27
运行在以下环境
系统 opensuse_Leap_42.2 libwpd * Up to
(excluding)
0.10.2-8.1
运行在以下环境
系统 opensuse_Leap_42.3 libwpd * Up to
(excluding)
0.10.2-8.1
运行在以下环境
系统 suse_12 libwpd-0_10-10 * Up to
(excluding)
0.10.2-2.4
运行在以下环境
系统 suse_12_SP2 libwpd * Up to
(excluding)
0.10.2-2.4.1
运行在以下环境
系统 suse_12_SP3 libwpd * Up to
(excluding)
0.10.2-2.4.1
运行在以下环境
系统 ubuntu_18.04.5_lts libwpd * Up to
(excluding)
0.10.2-2
运行在以下环境
系统 ubuntu_18.10 libwpd * Up to
(excluding)
0.10.2-2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况