中危 ImageMagick拒绝服务漏洞(CNVD-2017-27284)

CVE编号

CVE-2017-14528

利用情况

暂无

补丁情况

没有补丁

披露时间

2017-09-18
漏洞描述
ImageMagick是美国ImageMagick Studio公司的一套开源的图象处理软件。该软件可读取、转换、写入多种格式的图片。

ImageMagick 7.0.6版本中的coders/tiff.c文件的‘TIFFSetProfiles’函数存在拒绝服务漏洞。远程攻击者可借助特制的文件利用该漏洞造成拒绝服务(释放后重用和应用程序崩溃)。
解决建议
厂商尚未提供漏洞修复方案,请关注厂商主页及时更新:
https://www.imagemagick.org
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 imagemagick imagemagick 7.0.6 -
运行在以下环境
系统 debian_9 imagemagick * Up to
(excluding)
8:6.9.7.4+dfsg-11+deb9u11
运行在以下环境
系统 ubuntu_14.04.6_lts imagemagick * Up to
(excluding)
2019-03-25
运行在以下环境
系统 ubuntu_16.04.7_lts imagemagick * Up to
(excluding)
2019-03-25
运行在以下环境
系统 ubuntu_18.04 imagemagick * Up to
(excluding)
8:6.9.7.4+dfsg-16ubuntu6.11
运行在以下环境
系统 ubuntu_18.04.5_lts imagemagick * Up to
(excluding)
2019-03-25
运行在以下环境
系统 ubuntu_18.10 imagemagick * Up to
(excluding)
8:6.9.10.8+dfsg-1ubuntu2
阿里云评分
6.5
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    没有补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-416 释放后使用
阿里云安全产品覆盖情况