IBM DOORS Next Generation 4.0/5.0/6.0 Web UI 跨站脚本攻击

CVE编号

CVE-2017-1461

利用情况

暂无

补丁情况

N/A

披露时间

2017-11-28
漏洞描述
IBM Rational DOORS Next Generation(DNG)和Rational Requirements Composer(RRC)都是美国IBM公司的需求管理解决方案。该方案主要用于定义、管理和报告项目生命周期中的需求。

IBM DNG和RRC中存在跨站脚本漏洞,该漏洞源于程序未能充分的验证用户提交的输入。远程攻击者可利用该漏洞向Web UI注入任意的JavaScript代码。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://www.ibm.com/support/fixcentral/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 ibm rational_doors_next_generation * From
(including)
4.0
Up to
(including)
4.0.7
运行在以下环境
应用 ibm rational_doors_next_generation * From
(including)
5.0
Up to
(including)
5.0.2
运行在以下环境
应用 ibm rational_doors_next_generation * From
(including)
6.0
Up to
(including)
6.0.4
运行在以下环境
系统 debian_10 bareos * Up to
(excluding)
16.2.6-5
运行在以下环境
系统 debian_7 bareos * Up to
(excluding)
0.18.4-6+deb7u3
运行在以下环境
系统 debian_9 bareos * Up to
(excluding)
0.48.0-2+deb9u2
运行在以下环境
系统 debian_sid bareos * Up to
(excluding)
17.2.7-2.1
运行在以下环境
系统 fedora_25 bareos * Up to
(excluding)
0.45.0-9.fc25
运行在以下环境
系统 fedora_26 bareos * Up to
(excluding)
0.52.0-9.fc26
运行在以下环境
系统 fedora_27 bareos * Up to
(excluding)
0.57.0-5.fc27
运行在以下环境
系统 opensuse_Leap_42.3 bareos * Up to
(excluding)
0.43.0-8.1
运行在以下环境
系统 sles_12 libpoppler-glib8 * Up to
(excluding)
0.43.0-16.15
运行在以下环境
系统 sles_12_SP3 bareos * Up to
(excluding)
0.43.0-16.15.1
运行在以下环境
系统 suse_12 libpoppler-glib8 * Up to
(excluding)
0.43.0-16.15
运行在以下环境
系统 suse_12_SP3 libpoppler-glib8 * Up to
(excluding)
0.43.0-16.15.1
运行在以下环境
系统 ubuntu_14.04.6_lts poppler * Up to
(excluding)
0.24.5-2ubuntu4.7
运行在以下环境
系统 ubuntu_14.04_lts poppler * Up to
(excluding)
0.24.5-2ubuntu4.7
运行在以下环境
系统 ubuntu_16.04.7_lts poppler * Up to
(excluding)
0.41.0-0ubuntu1.4
运行在以下环境
系统 ubuntu_16.04_lts poppler * Up to
(excluding)
0.41.0-0ubuntu1.4
CVSS3评分
5.4
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    已更改
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况