中危 Red Hat GlusterFS拒绝服务漏洞(CNVD-2017-32891)

CVE编号

CVE-2017-15096

利用情况

暂无

补丁情况

没有补丁

披露时间

2017-10-27
漏洞描述
Red Hat GlusterFS是美国红帽(Red Hat)公司的一套开源的分布式文件系统。该系统是各种不同的存储服务器的组合,这些服务器由以太网或无限带宽技术Infiniband以及远程直接内存访问RDMA互相融汇,最终所形成的一个大的并行文件系统网络。

Red Hat GlusterFS 3.10之前的版本中的glusterfsd/src/gf_attach.c文件的‘send_brick_req’函数存在安全漏洞。攻击者可利用该漏洞造成拒绝服务(空指针逆向引用)。
解决建议
厂商尚未提供漏洞修复方案,请关注厂商主页更新:
https://www.gluster.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gluster glusterfs * Up to
(including)
3.9.0
运行在以下环境
系统 fedora_25 glu * Up to
(excluding)
3.10.6-4.fc25
运行在以下环境
系统 fedora_25 glusterfs-cli-debuginfo * Up to
(excluding)
3.10.6-4.fc25
运行在以下环境
系统 fedora_25 glusterfs-client-xlators-debuginfo * Up to
(excluding)
3.10.6-4.fc25
运行在以下环境
系统 fedora_25 glusterfs-fuse * Up to
(excluding)
3.10.6-4.fc25
运行在以下环境
系统 fedora_25 glusterfs-geo-replication * Up to
(excluding)
3.10.6-4.fc25
运行在以下环境
系统 fedora_25 glusterfs-libs-debuginfo * Up to
(excluding)
3.10.6-4.fc25
运行在以下环境
系统 fedora_26 glu * Up to
(excluding)
3.10.6-4.fc26
运行在以下环境
系统 fedora_26 glusterfs-cli-debuginfo * Up to
(excluding)
3.10.6-4.fc26
运行在以下环境
系统 fedora_26 glusterfs-client-xlators-debuginfo * Up to
(excluding)
3.10.6-4.fc26
运行在以下环境
系统 fedora_26 glusterfs-fuse * Up to
(excluding)
3.10.6-4.fc26
运行在以下环境
系统 fedora_26 glusterfs-geo-replication * Up to
(excluding)
3.10.6-4.fc26
运行在以下环境
系统 fedora_26 glusterfs-libs-debuginfo * Up to
(excluding)
3.10.6-4.fc26
运行在以下环境
系统 fedora_27 glu * Up to
(excluding)
3.12.2-2.fc27
运行在以下环境
系统 fedora_27 glusterfs-cli-debuginfo * Up to
(excluding)
3.12.2-2.fc27
运行在以下环境
系统 fedora_27 glusterfs-client-xlators-debuginfo * Up to
(excluding)
3.12.2-2.fc27
运行在以下环境
系统 fedora_27 glusterfs-fuse * Up to
(excluding)
3.12.2-2.fc27
运行在以下环境
系统 fedora_27 glusterfs-geo-replication * Up to
(excluding)
3.12.2-2.fc27
运行在以下环境
系统 fedora_27 glusterfs-libs-debuginfo * Up to
(excluding)
3.12.2-2.fc27
运行在以下环境
系统 ubuntu_18.04.5_lts glusterfs * Up to
(excluding)
3.13.2-1build1
运行在以下环境
系统 ubuntu_18.10 glusterfs * Up to
(excluding)
3.13.2-1build1
阿里云评分
5.9
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    普通权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    没有补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-476 空指针解引用
阿里云安全产品覆盖情况