低危 libxml2 xmlXPathCompOpEvalPositionalPredicate内存错误引用漏洞

CVE编号

CVE-2017-15412

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-08-29
漏洞描述
在63.0.3239.84之前的Google Chrome和其他产品中使用的2.9.5之前的libxml2中的UAF 允许远程攻击者通过精心制作的HTML页面利用堆破坏。

解决建议
用户可参考如下供应商提供的安全公告获得补丁信息:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=883790
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 google chrome * Up to
(excluding)
63.0.3239.84
运行在以下环境
应用 xmlsoft libxml2 * Up to
(excluding)
2.9.5
运行在以下环境
系统 debian debian_linux 7.0 -
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 debian debian_linux 9.0 -
运行在以下环境
系统 redhat enterprise_linux_desktop 6.0 -
运行在以下环境
系统 redhat enterprise_linux_server 6.0 -
运行在以下环境
系统 redhat enterprise_linux_workstation 6.0 -
运行在以下环境
系统 redhat_7 libxml2 * Up to
(excluding)
0:2.9.1-6.el7.4
运行在以下环境
系统 sles_12 libxml2 * Up to
(excluding)
2.9.4-46.12
运行在以下环境
系统 suse_12 libxml2 * Up to
(excluding)
2.9.4-46.12
运行在以下环境
系统 ubuntu_14.04.6_lts chromium-browser * Up to
(excluding)
63.0.3239.84-0ubuntu0.14.04.1
运行在以下环境
系统 ubuntu_14.04_lts chromium-browser * Up to
(excluding)
63.0.3239.84-0ubuntu0.14.04.1
运行在以下环境
系统 ubuntu_14.04_lts libxml2 * Up to
(excluding)
2.9.1+dfsg1-3ubuntu4.12
运行在以下环境
系统 ubuntu_16.04.7_lts chromium-browser * Up to
(excluding)
63.0.3239.84-0ubuntu0.16.04.1
运行在以下环境
系统 ubuntu_16.04_lts chromium-browser * Up to
(excluding)
63.0.3239.84-0ubuntu0.16.04.1
运行在以下环境
系统 ubuntu_18.04.5_lts chromium-browser * Up to
(excluding)
63.0.3239.84-0ubuntu1
运行在以下环境
系统 ubuntu_18.04_lts chromium-browser * Up to
(excluding)
63.0.3239.84-0ubuntu1
运行在以下环境
系统 ubuntu_18.10 chromium-browser * Up to
(excluding)
63.0.3239.84-0ubuntu1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-416 释放后使用
阿里云安全产品覆盖情况