低危 Apache HTTP Server up to 2.0.65/2.2.34/2.4.29 mod_authnz_ldap Crash 拒绝服务漏洞

CVE编号

CVE-2017-15710

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-03-27
漏洞描述
在Apache httpd 2.0.23到2.0.65、2.2.0到2.2.34和2.4.0到2.4.29中,mod_authnz_ldap(如果配置了AuthLDAPCharsetConfig)使用Accept-Language头值在验证用户凭证时查找正确的字符集编码。如果charset转换表中没有header value ,则使用回退机制将其截断为两个字符的值,以便快速重试(例如,'en- us '被截断为'en')。小于两个字符的header value 强制将一个NUL字节的无约束写入不属于字符串的内存位置。在最坏的情况下,进程崩溃的可能性很小,这可能被用作拒绝服务攻击。在更有可能的情况下,这个内存已经预留给将来使用,并且这个问题根本没有影响。

解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://www.apache.org/
参考链接
http://www.openwall.com/lists/oss-security/2018/03/24/8
http://www.securityfocus.com/bid/103512
http://www.securitytracker.com/id/1040569
https://access.redhat.com/errata/RHSA-2018:3558
https://access.redhat.com/errata/RHSA-2019:0366
https://access.redhat.com/errata/RHSA-2019:0367
https://httpd.apache.org/security/vulnerabilities_24.html
https://lists.apache.org/thread.html/56c2e7cc9deb1c12a843d0dc251ea7fd3e7e8029...
https://lists.apache.org/thread.html/84a3714f0878781f6ed84473d1a503d2cc382277...
https://lists.apache.org/thread.html/r04e89e873d54116a0635ef2f7061c15acc5ed27...
https://lists.apache.org/thread.html/r06f0d87ebb6d59ed8379633f36f72f5b1f79cad...
https://lists.apache.org/thread.html/r6521a7f62276340eabdb3339b2aa9a38c5f59d9...
https://lists.apache.org/thread.html/r76142b8c5119df2178be7c2dba88fde552eedee...
https://lists.apache.org/thread.html/r9f93cf6dde308d42a9c807784e8102600d0397f...
https://lists.apache.org/thread.html/rc998b18880df98bafaade071346690c2bc1444a...
https://lists.apache.org/thread.html/rd18c3c43602e66f9cdcf09f1de233804975b957...
https://lists.apache.org/thread.html/re1e3a24664d35bcd0a0e793e0b5fc6ca6c107f9...
https://lists.apache.org/thread.html/re3d27b6250aa8548b8845d314bb8a350b3df326...
https://lists.apache.org/thread.html/rf6449464fd8b7437704c55f88361b66f12d5b5f...
https://lists.debian.org/debian-lts-announce/2018/05/msg00020.html
https://security.netapp.com/advisory/ntap-20180601-0004/
https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-...
https://usn.ubuntu.com/3627-1/
https://usn.ubuntu.com/3627-2/
https://usn.ubuntu.com/3937-2/
https://www.debian.org/security/2018/dsa-4164
https://www.tenable.com/security/tns-2019-09
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache http_server 2.4.1 -
运行在以下环境
应用 apache http_server 2.4.10 -
运行在以下环境
应用 apache http_server 2.4.12 -
运行在以下环境
应用 apache http_server 2.4.16 -
运行在以下环境
应用 apache http_server 2.4.17 -
运行在以下环境
应用 apache http_server 2.4.18 -
运行在以下环境
应用 apache http_server 2.4.2 -
运行在以下环境
应用 apache http_server 2.4.20 -
运行在以下环境
应用 apache http_server 2.4.23 -
运行在以下环境
应用 apache http_server 2.4.25 -
运行在以下环境
应用 apache http_server 2.4.26 -
运行在以下环境
应用 apache http_server 2.4.27 -
运行在以下环境
应用 apache http_server 2.4.28 -
运行在以下环境
应用 apache http_server 2.4.29 -
运行在以下环境
应用 apache http_server 2.4.3 -
运行在以下环境
应用 apache http_server 2.4.4 -
运行在以下环境
应用 apache http_server 2.4.6 -
运行在以下环境
应用 apache http_server 2.4.7 -
运行在以下环境
应用 apache http_server 2.4.9 -
运行在以下环境
应用 netapp santricity_cloud_connector - -
运行在以下环境
应用 netapp storagegrid - -
运行在以下环境
应用 netapp storage_automation_store - -
运行在以下环境
系统 redhat_7 httpd * Up to
(excluding)
0:2.4.6-93.el7
运行在以下环境
系统 suse_12 apache2 * Up to
(excluding)
2.4.16-20.16
运行在以下环境
系统 ubuntu_14.04_lts apache2 * Up to
(excluding)
2.4.7-1ubuntu4.20
运行在以下环境
系统 ubuntu_16.04_lts apache2 * Up to
(excluding)
2.4.18-2ubuntu3.8
运行在以下环境
系统 ubuntu_18.04_lts apache2 * Up to
(excluding)
2.4.29-1ubuntu4.1
运行在以下环境
系统 ubuntu_18.10 apache2 * Up to
(excluding)
2.4.29-1ubuntu4.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况