严重 Apache Httpd 解析漏洞

CVE编号

CVE-2017-15715

利用情况

EXP 已公开

补丁情况

官方补丁

披露时间

2018-03-27
该漏洞EXP已公开传播,漏洞利用成本极低,建议您立即关注并修复。
漏洞描述
Apache httpd是美国阿帕奇(Apache)软件基金会的一款专为现代操作系统开发和维护的开源HTTP服务器。

Apache httpd 2.4.0版本至2.4.29版本中存在安全漏洞。攻击者可通过向目标系统发送特制的文件利用该漏洞绕过安全限制。
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
http://httpd.apache.org/security/vulnerabilities_24.html#CVE-2017-15715
参考链接
http://www.openwall.com/lists/oss-security/2018/03/24/6
http://www.securityfocus.com/bid/103525
http://www.securitytracker.com/id/1040570
https://access.redhat.com/errata/RHSA-2018:3558
https://access.redhat.com/errata/RHSA-2019:0366
https://access.redhat.com/errata/RHSA-2019:0367
https://httpd.apache.org/security/vulnerabilities_24.html
https://lists.apache.org/thread.html/56c2e7cc9deb1c12a843d0dc251ea7fd3e7e8029...
https://lists.apache.org/thread.html/84a3714f0878781f6ed84473d1a503d2cc382277...
https://lists.apache.org/thread.html/r04e89e873d54116a0635ef2f7061c15acc5ed27...
https://lists.apache.org/thread.html/r06f0d87ebb6d59ed8379633f36f72f5b1f79cad...
https://lists.apache.org/thread.html/r6521a7f62276340eabdb3339b2aa9a38c5f59d9...
https://lists.apache.org/thread.html/r76142b8c5119df2178be7c2dba88fde552eedee...
https://lists.apache.org/thread.html/r9f93cf6dde308d42a9c807784e8102600d0397f...
https://lists.apache.org/thread.html/rc998b18880df98bafaade071346690c2bc1444a...
https://lists.apache.org/thread.html/rd18c3c43602e66f9cdcf09f1de233804975b957...
https://lists.apache.org/thread.html/rd336919f655b7ff309385e34a143e41c503e133...
https://lists.apache.org/thread.html/re1e3a24664d35bcd0a0e793e0b5fc6ca6c107f9...
https://lists.apache.org/thread.html/re3d27b6250aa8548b8845d314bb8a350b3df326...
https://lists.apache.org/thread.html/rf6449464fd8b7437704c55f88361b66f12d5b5f...
https://security.elarlang.eu/cve-2017-15715-apache-http-server-filesmatch-byp...
https://security.netapp.com/advisory/ntap-20180601-0004/
https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-...
https://usn.ubuntu.com/3627-1/
https://usn.ubuntu.com/3627-2/
https://www.debian.org/security/2018/dsa-4164
https://www.tenable.com/security/tns-2019-09
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache http_server * From
(including)
2.4.0
Up to
(including)
2.4.29
运行在以下环境
系统 alibaba_cloud_linux_2.1903 httpd * Up to
(excluding)
2.4.6-95.2.al7
运行在以下环境
系统 alpine_3.10 httpd * Up to
(excluding)
2.4.33-r0
运行在以下环境
系统 alpine_3.11 httpd * Up to
(excluding)
2.4.33-r0
运行在以下环境
系统 alpine_3.12 httpd * Up to
(excluding)
2.4.33-r0
运行在以下环境
系统 alpine_3.13 httpd * Up to
(excluding)
2.4.33-r0
运行在以下环境
系统 alpine_3.14 httpd * Up to
(excluding)
2.4.33-r0
运行在以下环境
系统 alpine_3.15 httpd * Up to
(excluding)
2.4.33-r0
运行在以下环境
系统 alpine_3.4 httpd * Up to
(excluding)
2.4.33-r0
运行在以下环境
系统 alpine_3.5 httpd * Up to
(excluding)
2.4.33-r0
运行在以下环境
系统 alpine_3.6 httpd * Up to
(excluding)
2.4.33-r0
运行在以下环境
系统 alpine_3.7 httpd * Up to
(excluding)
2.4.33-r0
运行在以下环境
系统 alpine_3.8 httpd * Up to
(excluding)
2.4.33-r0
运行在以下环境
系统 alpine_3.9 httpd * Up to
(excluding)
2.4.33-r0
运行在以下环境
系统 alpine_edge httpd * Up to
(excluding)
2.4.33-r0
运行在以下环境
系统 amazon_AMI httpd * Up to
(excluding)
2.4.33-2.78.amzn1
运行在以下环境
系统 debian_8 httpd * Up to
(excluding)
2.4.10-10+deb8u5
运行在以下环境
系统 debian_9 httpd * Up to
(excluding)
2.4.25-3+deb9u4
运行在以下环境
系统 fedora_26 httpd * Up to
(excluding)
2.4.33-2.fc26
运行在以下环境
系统 fedora_27 httpd * Up to
(excluding)
2.4.33-2.fc27
运行在以下环境
系统 fedora_28 httpd * Up to
(excluding)
2.4.33-2.fc28
运行在以下环境
系统 opensuse_Leap_42.3 httpd * Up to
(excluding)
2.4.23-22.1
运行在以下环境
系统 oracle_7 httpd * Up to
(excluding)
2.4.6-95.0.1.el7
运行在以下环境
系统 redhat_7 httpd * Up to
(excluding)
0:2.4.6-95.el7
运行在以下环境
系统 suse_12 apache2 * Up to
(excluding)
2.4.16-20.16
运行在以下环境
系统 suse_12_SP3 httpd * Up to
(excluding)
2.4.23-29.18.2
运行在以下环境
系统 ubuntu_14.04 httpd * Up to
(excluding)
2.4.7-1ubuntu4.20
运行在以下环境
系统 ubuntu_14.04.6_lts apache2 * Up to
(excluding)
2.4.7-1ubuntu4.20
运行在以下环境
系统 ubuntu_16.04 httpd * Up to
(excluding)
2.4.18-2ubuntu3.8
运行在以下环境
系统 ubuntu_16.04.7_lts apache2 * Up to
(excluding)
2.4.18-2ubuntu3.8
运行在以下环境
系统 ubuntu_18.04 httpd * Up to
(excluding)
2.4.29-1ubuntu4.1
运行在以下环境
系统 ubuntu_18.04.5_lts apache2 * Up to
(excluding)
2.4.29-1ubuntu4.1
阿里云评分
9.4
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    EXP 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况