低危 Ceph up to 12.1.0 RADOS Gateway rgw/rgw_iam_policy.cc 拒绝服务漏洞

CVE编号

CVE-2017-16818

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-12-21
漏洞描述
Red Hat Ceph是美国红帽(Red Hat)公司的一套Linux PB级分布式文件系统。该系统的主要目标是设计成基于POSIX(可移植操作系统接口)的没有单点故障的分布式文件系统,使数据能容错和无缝的复制。RADOS Gateway是其中的一个对象存储网关。

Red Hat Ceph中的RADOS Gateway存在拒绝服务漏洞。远程攻击者可利用该漏洞造成拒绝服务(断言失败和应用程序退出)。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/ceph/ceph/commit/b3118cabb8060a8cc6a01c4e8264cb18e7b1745a
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat ceph * From
(including)
12.1.0
Up to
(including)
12.2.1
运行在以下环境
系统 fedora_27 ceph-base * Up to
(excluding)
12.2.2-1.fc27
运行在以下环境
系统 fedora_27 ceph-debugsource * Up to
(excluding)
12.2.2-1.fc27
运行在以下环境
系统 fedora_27 ceph-mgr-debuginfo * Up to
(excluding)
12.2.2-1.fc27
运行在以下环境
系统 fedora_27 lib * Up to
(excluding)
12.2.2-1.fc27
运行在以下环境
系统 fedora_27 librados-devel * Up to
(excluding)
12.2.2-1.fc27
运行在以下环境
系统 fedora_27 libradosstriper1 * Up to
(excluding)
12.2.2-1.fc27
运行在以下环境
系统 fedora_27 python-rgw * Up to
(excluding)
12.2.2-1.fc27
运行在以下环境
系统 fedora_27 python-rgw-debuginfo * Up to
(excluding)
12.2.2-1.fc27
运行在以下环境
系统 fedora_27 python3-cephfs * Up to
(excluding)
12.2.2-1.fc27
运行在以下环境
系统 opensuse_Leap_42.3 ceph-base * Up to
(excluding)
12.2.5
运行在以下环境
系统 opensuse_Leap_42.3 ceph-debugsource * Up to
(excluding)
12.2.5
运行在以下环境
系统 opensuse_Leap_42.3 ceph-mgr-debuginfo * Up to
(excluding)
12.2.5
运行在以下环境
系统 opensuse_Leap_42.3 lib * Up to
(excluding)
12.2.5
运行在以下环境
系统 opensuse_Leap_42.3 librados-devel * Up to
(excluding)
12.2.5
运行在以下环境
系统 opensuse_Leap_42.3 libradosstriper1 * Up to
(excluding)
12.2.5
运行在以下环境
系统 opensuse_Leap_42.3 python-rgw * Up to
(excluding)
12.2.5
运行在以下环境
系统 opensuse_Leap_42.3 python-rgw-debuginfo * Up to
(excluding)
12.2.5
运行在以下环境
系统 opensuse_Leap_42.3 python3-cephfs * Up to
(excluding)
12.2.5
运行在以下环境
系统 suse_12 ceph * Up to
(excluding)
12.2.5+git.1524775272.5e7ea8cf03-2.7
运行在以下环境
系统 suse_12_SP3 ceph-base * Up to
(excluding)
12.2.5
运行在以下环境
系统 suse_12_SP3 ceph-debugsource * Up to
(excluding)
12.2.5
运行在以下环境
系统 suse_12_SP3 ceph-mgr-debuginfo * Up to
(excluding)
12.2.5
运行在以下环境
系统 suse_12_SP3 lib * Up to
(excluding)
12.2.5
运行在以下环境
系统 suse_12_SP3 librados-devel * Up to
(excluding)
12.2.5
运行在以下环境
系统 suse_12_SP3 libradosstriper1 * Up to
(excluding)
12.2.5
运行在以下环境
系统 suse_12_SP3 python-rgw * Up to
(excluding)
12.2.5
运行在以下环境
系统 suse_12_SP3 python-rgw-debuginfo * Up to
(excluding)
12.2.5
运行在以下环境
系统 suse_12_SP3 python3-cephfs * Up to
(excluding)
12.2.5
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-617 可达断言
阿里云安全产品覆盖情况