IBM Integration Bus会话劫持漏洞

CVE编号

CVE-2017-1693

利用情况

暂无

补丁情况

N/A

披露时间

2018-01-20
漏洞描述
IBM Integration Bus(前称IBM WebSphere Message Broker)是美国IBM公司的一款企业服务总线(ESB)产品。该产品为面向服务架构(SOA)环境和非SOA环境提供连通性和通用数据转换。

IBM Integration Bus存在会话劫持漏洞。有效会话id的攻击者可利用该漏洞在会话超时之前的较短时间内劫持另一位用户的会话。
解决建议
厂商已发布漏洞修复程序,请及时关注更新:
http://www-01.ibm.com/support/docview.wss?uid=swg22012642
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 ibm integration_bus 10.0 -
运行在以下环境
应用 ibm integration_bus 10.0.0.0 -
运行在以下环境
应用 ibm integration_bus 10.0.0.1 -
运行在以下环境
应用 ibm integration_bus 10.0.0.2 -
运行在以下环境
应用 ibm integration_bus 10.0.0.3 -
运行在以下环境
应用 ibm integration_bus 10.0.0.4 -
运行在以下环境
应用 ibm integration_bus 10.0.0.5 -
运行在以下环境
应用 ibm integration_bus 10.0.0.6 -
运行在以下环境
应用 ibm integration_bus 10.0.0.7 -
运行在以下环境
应用 ibm integration_bus 10.0.0.8 -
运行在以下环境
应用 ibm integration_bus 10.0.0.9 -
运行在以下环境
应用 ibm integration_bus 9.0.0.0 -
运行在以下环境
应用 ibm integration_bus 9.0.0.1 -
运行在以下环境
应用 ibm integration_bus 9.0.0.2 -
运行在以下环境
应用 ibm integration_bus 9.0.0.3 -
运行在以下环境
应用 ibm integration_bus 9.0.0.4 -
运行在以下环境
应用 ibm integration_bus 9.0.0.5 -
运行在以下环境
应用 ibm integration_bus 9.0.0.6 -
运行在以下环境
应用 ibm integration_bus 9.0.0.7 -
运行在以下环境
应用 ibm integration_bus 9.0.0.8 -
运行在以下环境
系统 amazon_2 kernel * Up to
(excluding)
4.14.42-61.37.amzn2
运行在以下环境
系统 amazon_AMI kernel * Up to
(excluding)
4.14.42-52.37.amzn1
运行在以下环境
系统 fedora_25 kernel * Up to
(excluding)
0.7.6-6.fc25
运行在以下环境
系统 fedora_26 kernel * Up to
(excluding)
0.7.6-6.fc26
运行在以下环境
系统 fedora_27 kernel * Up to
(excluding)
0.7.6-5.fc27
运行在以下环境
系统 fedora_EPEL_6 kernel * Up to
(excluding)
0.7.6-6.el6
运行在以下环境
系统 opensuse_Leap_42.2 kernel * Up to
(excluding)
0.7.5-14.1
运行在以下环境
系统 opensuse_Leap_42.3 kernel * Up to
(excluding)
0.7.5-14.1
运行在以下环境
系统 oracle_7 kernel * Up to
(excluding)
3.10.0-862.2.3.el7
运行在以下环境
系统 redhat_7 kernel * Up to
(excluding)
0:3.10.0-862.2.3.el7
运行在以下环境
系统 redhat_7 kernel-rt * Up to
(excluding)
0:3.10.0-862.2.3.rt56.806.el7
运行在以下环境
系统 suse_11 libxml2 * Up to
(excluding)
2.7.6-0.77.10
运行在以下环境
系统 suse_11_SP4 kernel * Up to
(excluding)
2.7.6-0.77.10.1
运行在以下环境
系统 suse_12 kernel-default-extra * Up to
(excluding)
4.12.14-94.41
运行在以下环境
系统 suse_12_SP2 kernel * Up to
(excluding)
4.4.90-92.50.1
运行在以下环境
系统 suse_12_SP3 kernel * Up to
(excluding)
4.4.92-6.30.1
运行在以下环境
系统 ubuntu_14.04.6_lts libxml2 * Up to
(excluding)
2.9.1+dfsg1-3ubuntu4.10
运行在以下环境
系统 ubuntu_16.04.7_lts linux * Up to
(excluding)
4.4.0-103.126
运行在以下环境
系统 ubuntu_18.04.5_lts linux * Up to
(excluding)
4.13.0-25.29
运行在以下环境
系统 ubuntu_18.10 optipng * Up to
(excluding)
0.7.6-1.1
CVSS3评分
5.6
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-613 不充分的会话过期机制
阿里云安全产品覆盖情况