低危 libxml2存在未明漏洞(CNVD-2017-38272)

CVE编号

CVE-2017-16931

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-11-24
漏洞描述
libxml2是GNOME项目组所研发的一个基于C语言的用来解析XML文档的函数库,它支持多种编码格式、Xpath解析、Well-formed和valid验证等。

libxml2 2.9.5之前的版本中的parser.c文件存在安全漏洞,该漏洞源于程序未能正确的处理参数实体的逆向引用。攻击者可利用该漏洞更改xmlParseNameComplex和xmlDictLookup中的输入缓冲区。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/GNOME/libxml2/commit/e26630548e7d138d2c560844c43820b6767251e3
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 xmlsoft libxml2 * Up to
(including)
2.9.4
运行在以下环境
系统 alpine_3.4 libxml2 * Up to
(excluding)
2.9.5-r0
运行在以下环境
系统 alpine_3.5 libxml2 * Up to
(excluding)
2.9.5-r0
运行在以下环境
系统 alpine_3.6 libxml2 * Up to
(excluding)
2.9.5-r0
运行在以下环境
系统 amazon_2 libxml2 * Up to
(excluding)
2.9.1-6.amzn2.3.3
运行在以下环境
系统 debian_7 libxml2 * Up to
(excluding)
2.8.0+dfsg1-7+wheezy11
运行在以下环境
系统 debian_8 libxml2 * Up to
(excluding)
2.9.1+dfsg1-5+deb8u4
运行在以下环境
系统 debian_9 libxml2 * Up to
(excluding)
2.9.4+dfsg1-2.2+deb9u1
运行在以下环境
系统 ubuntu_14.04.6_lts libxml2 * Up to
(excluding)
2.9.1+dfsg1-3ubuntu4.10
运行在以下环境
系统 ubuntu_16.04.7_lts libxml2 * Up to
(excluding)
2.9.3+dfsg1-1ubuntu0.3
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况