低危 Vim信息泄露漏洞(CNVD-2017-38252)

CVE编号

CVE-2017-17087

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-12-01
漏洞描述
Vim是从vi发展出来的一个文本编辑器。

8.0.1263之前的Vim存在信息泄露漏洞。该漏洞产生的原因是Vim中的fileio.c将.swp文件的组所有权设置为编辑器的主组(可能不同于原始文件的组所有权)。本地用户可利用漏洞通过利用适用的组员资格获取敏感信息。
解决建议
厂商已发布漏洞修复程序,请及时关注更新:
https://github.com/vim/vim/commit/5a73e0ca54c77e067c3b12ea6f35e3e8681e8cf8
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 vim vim * Up to
(excluding)
8.0.1263
运行在以下环境
系统 debian_8 vim * Up to
(excluding)
2:7.4.488-7+deb8u3
运行在以下环境
系统 debian_9 vim * Up to
(excluding)
2:8.0.0197-4+deb9u4
运行在以下环境
系统 ubuntu_16.04 vim * Up to
(excluding)
2:7.4.1689-3ubuntu1.5
运行在以下环境
系统 ubuntu_16.04.7_lts vim * Up to
(excluding)
2:7.4.1689-3ubuntu1.5
运行在以下环境
系统 ubuntu_18.04.5_lts vim * Up to
(excluding)
2:8.0.1453-1ubuntu1
运行在以下环境
系统 ubuntu_18.10 vim * Up to
(excluding)
2:8.0.1453-1ubuntu1
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-200 信息暴露
CWE-668 将资源暴露给错误范围
阿里云安全产品覆盖情况