中危 拒绝服务漏洞

CVE编号

CVE-2017-18224

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-03-12
漏洞描述
在4.15之前的linux内核中,fs/ocfs2/aops.c省略了 semaphore的使用,因此在DIRECT模式下读取操作期间具有访问extent tree的竞争条件,这允许本地用户通过修改特定ecpos字段导致拒绝服务(bug)。 

解决建议
厂商已发布漏洞修复程序,请及时关注更新:
https://github.com/torvalds/linux/commit/3e4c56d41eef5595035872a2ec5a483f42e8917f
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 debian_9 linux * Up to
(excluding)
4.9.88-1
运行在以下环境
系统 linux linux_kernel * Up to
(excluding)
4.15
运行在以下环境
系统 opensuse_Leap_15.0 linux * Up to
(excluding)
4.12.14-lp150.12.25.1
运行在以下环境
系统 sles_12 kernel-default-extra * Up to
(excluding)
4.12.14-120
运行在以下环境
系统 sles_12_SP4 linux * Up to
(excluding)
4.12.14-6.3.1
运行在以下环境
系统 suse_12 kernel-default-extra * Up to
(excluding)
4.12.14-120
运行在以下环境
系统 suse_12_SP4 linux * Up to
(excluding)
4.12.14-6.3.1
运行在以下环境
系统 ubuntu_14.04.6_lts linux-azure * Up to
(excluding)
4.15.0-1023.24~14.04.1
运行在以下环境
系统 ubuntu_14.04_lts linux-azure * Up to
(excluding)
4.15.0-1023.24~14.04.1
运行在以下环境
系统 ubuntu_16.04 linux * Up to
(excluding)
4.15.0-1013.13~16.04.2
运行在以下环境
系统 ubuntu_16.04.7_lts linux-azure * Up to
(excluding)
4.15.0-1013.13~16.04.2
运行在以下环境
系统 ubuntu_16.04_lts linux-azure * Up to
(excluding)
4.15.0-1013.13~16.04.2
运行在以下环境
系统 ubuntu_18.04 linux * Up to
(excluding)
4.18.0-1003.3~18.04.1
运行在以下环境
系统 ubuntu_18.04.5_lts linux * Up to
(excluding)
4.15.0-10.11
运行在以下环境
系统 ubuntu_18.04_lts linux * Up to
(excluding)
4.15.0-10.11
运行在以下环境
系统 ubuntu_18.10 linux * Up to
(excluding)
4.15.0-20.21
阿里云评分
5.2
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-362 使用共享资源的并发执行不恰当同步问题(竞争条件)
阿里云安全产品覆盖情况