低危 在LXC 2.0中,许多模板脚本通过明文HTTP下载代码,并省略了数字签名检查。

CVE编号

CVE-2017-18641

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-02-10
漏洞描述
在LXC 2.0中,许多模板脚本通过明文HTTP下载代码,并忽略数字签名检查,然后再运行它来引导容器。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 linuxcontainers lxc 2.0.0 -
运行在以下环境
系统 debian_10 lxc * Up to
(excluding)
1:3.0.3-1
运行在以下环境
系统 debian_11 lxc * Up to
(excluding)
1:3.0.3-1
运行在以下环境
系统 debian_12 lxc * Up to
(excluding)
1:3.0.3-1
运行在以下环境
系统 debian_9 lxc * Up to
(including)
2.0.7-2+deb9u2
运行在以下环境
系统 ubuntu_18.04.5_lts lxc * Up to
(excluding)
3.0.3-0ubuntu1~18.04.1
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-287 认证机制不恰当
阿里云安全产品覆盖情况