Puppet Enterprise MCollective服务器安装任意包漏洞

CVE编号

CVE-2017-2293

利用情况

暂无

补丁情况

N/A

披露时间

2018-02-02
漏洞描述
Puppet是美国Puppet实验室的一套基于客户端/服务器(C/S)架构的配置管理工具,它可用于管理配置文件、用户、cron任务、软件包、系统服务等。Puppet Enterprise是一个企业版。MCollective Server是其中的一个MCollective服务器。

Puppet Enterprise 2016.4.5之前版本和2017.2.1之前版本中的MCollective服务器存在安全漏洞。攻击者可利用该漏洞安装或删除代理上的任意包。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://puppet.com/security/cve/cve-2017-2293
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 puppet puppet * Up to
(excluding)
2016.4.5
运行在以下环境
应用 puppet puppet 2016.5.1 -
运行在以下环境
应用 puppet puppet 2016.5.2 -
运行在以下环境
应用 puppet puppet 2017.1.0 -
运行在以下环境
应用 puppet puppet 2017.1.1 -
CVSS3评分
4.9
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况