Puppet Enterprise不正确凭证管理漏洞

CVE编号

CVE-2017-2297

利用情况

暂无

补丁情况

N/A

披露时间

2018-02-02
漏洞描述
Puppet是美国Puppet实验室的一套基于客户端/服务器(C/S)架构的配置管理工具,它可用于管理配置文件、用户、cron任务、软件包、系统服务等。Puppet Enterprise是一个企业版。

Puppet Enterprise 2016.4.5之前的版本和2017.2.1之前的版本中存在安全漏洞。该漏洞产生的原因是Puppet Enterprise在返回带标签的RBAC访问令牌之前未能能正确认证用户。目前没有详细的漏洞细节提供。
解决建议
厂商已发布漏洞修复程序,请及时关注更新:
https://puppet.com/security/cve/cve-2017-2297
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 puppet puppet * Up to
(excluding)
2016.4.5
运行在以下环境
应用 puppet puppet 2016.5.1 -
运行在以下环境
应用 puppet puppet 2016.5.2 -
运行在以下环境
应用 puppet puppet 2017.1.0 -
运行在以下环境
应用 puppet puppet 2017.1.1 -
CVSS3评分
7.5
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-287 认证机制不恰当
阿里云安全产品覆盖情况