低危 会话密钥中的weak entropy 使用

CVE编号

CVE-2017-2626

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-07-28
漏洞描述
j结果发现,1.0.9-8之前的libICE使用weak entropy来生成密钥。本地攻击者可以使用进程列表中提供的信息潜在地使用此缺陷进行会话劫持。 

解决建议
用户可参考如下厂商提供的安全补丁以修复该漏洞:
https://www.x.org/wiki/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 freedesktop libice * Up to
(including)
1.0.9
运行在以下环境
系统 alpine_3.11 libice * Up to
(excluding)
1.0.10-r0
运行在以下环境
系统 alpine_3.12 libice * Up to
(excluding)
1.0.10-r0
运行在以下环境
系统 alpine_3.13 libice * Up to
(excluding)
1.0.10-r0
运行在以下环境
系统 alpine_3.14 libice * Up to
(excluding)
1.0.10-r0
运行在以下环境
系统 alpine_3.15 libice * Up to
(excluding)
1.0.10-r0
运行在以下环境
系统 alpine_3.16 libice * Up to
(excluding)
1.0.10-r0
运行在以下环境
系统 alpine_edge libice * Up to
(excluding)
1.0.10-r0
运行在以下环境
系统 debian DPKG * Up to
(excluding)
2:1.0.9-2
运行在以下环境
系统 debian_8 libice * Up to
(excluding)
2:1.0.9-1+deb8u1
运行在以下环境
系统 fedora_24 libice * Up to
(excluding)
1.0.9-8.fc24
运行在以下环境
系统 fedora_25 libice * Up to
(excluding)
1.0.9-8.fc25
运行在以下环境
系统 fedora_26 libice * Up to
(excluding)
1.0.9-8.fc26
运行在以下环境
系统 opensuse_Leap_42.2 libice * Up to
(excluding)
1.0.9-5.3.1
运行在以下环境
系统 oracle_7 libice * Up to
(excluding)
1.1.5-3.el7
运行在以下环境
系统 redhat_7 xorg-x11-proto-devel * Up to
(excluding)
0:7.7-20.el7
运行在以下环境
系统 suse_11_SP4 libice * Up to
(excluding)
7.4-3.1
运行在以下环境
系统 suse_12 libICE * Up to
(excluding)
1.0.8-10
运行在以下环境
系统 suse_12_SP2 libice * Up to
(excluding)
1.0.8-10.1
运行在以下环境
系统 suse_12_SP3 libice * Up to
(excluding)
1.0.8-12.1
运行在以下环境
系统 ubuntu_18.04.5_lts libice * Up to
(excluding)
2:1.0.9-2
运行在以下环境
系统 ubuntu_18.10 libice * Up to
(excluding)
2:1.0.9-2
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-331 信息熵不充分
阿里云安全产品覆盖情况