中危 Clusterlabs PCS up to 0.9.156 Node Name 跨站脚本攻击

CVE编号

CVE-2017-2661

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-03-13
漏洞描述
ClusterLabs pcs是一款用于配置Pacemaker的命令行工具。

ClusterLabs pcs 0.9.157之前的版本中存在跨站脚本漏洞,该漏洞源于程序未能正确的校验Node名称字段。攻击者可利用该漏洞运行JavaScript代码。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/ClusterLabs/pcs/commit/1874a769b5720ae5430f10c6cedd234430bc703f
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 clusterlabs pcs * Up to
(excluding)
0.9.157
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0.9.155+dfsg-2
运行在以下环境
系统 debian_10 pcs * Up to
(excluding)
0.9.155+dfsg-2
运行在以下环境
系统 debian_11 pcs * Up to
(excluding)
0.9.155+dfsg-2
运行在以下环境
系统 debian_12 pcs * Up to
(excluding)
0.9.155+dfsg-2
运行在以下环境
系统 fedora_24 pcs-debuginfo * Up to
(excluding)
0.9.156-2.fc24
运行在以下环境
系统 fedora_25 pcs-debuginfo * Up to
(excluding)
0.9.156-2.fc25
运行在以下环境
系统 ubuntu_18.04.5_lts pcs * Up to
(excluding)
0.9.164-1
运行在以下环境
系统 ubuntu_18.10 pcs * Up to
(excluding)
0.9.164-1
阿里云评分
4.9
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况